Needs work
Project:
FileField Nginx Progress
Version:
6.x-1.4
Component:
Miscellaneous
Priority:
Normal
Category:
Support request
Assigned:
Unassigned
Reporter:
Created:
18 Jan 2011 at 02:37 UTC
Updated:
6 May 2011 at 11:42 UTC
Hi guys,
I have nginxinstalled and working great with the mod.. except when an image is uploaded it is giving me the http 0 error as it is being uploaded. The images still goes up ok etc.. and I know this is due to securepages... I tried to add the ignore in securepages but because "all" data gets served this way from nginx you cant use the standard nginx_filefield_uploadprogress/* ignore... as I found out the hard way it disables all your sites https access...
Anyways around this?
Cheers.
Comments
Comment #1
smoothify commentedI managed to reproduce this on a site that has securepages and its caused because secure pages initiates a redirect when the progress url is accessed - which is not followed by javascript.
I managed to fix it by adding the following to secure pages ignore list.
I know you mentioned it disabled your https, but for me it worked fine.
Comment #2
smoothify commentedComment #3
Poieo commentedI have this issue as well, http 0 error when using secure pages. Adding filefield_nginx_progress/* to the list of pages to ignore does eliminate the error, however, it does not fix the progress bar.
Using this module, together with secure pages (configured properly - I think), results in a 'spinning' progress bar for the duration of the upload. No 'progress' is ever actually shown, just the grey bar.