I am having some problems understanding how Drupal is handling file and directory permissions.
I have been troubleshooting an issue... with a little help. Here is the thread describing part 1.

http://drupal.org/node/1090428#comment-4201968

The problem I am having is I am not sure why I am getting the following error when I attempt to upload a new logo picture into the Bartik theme.

"The specified file temporary://websitelogo.jpg could not be copied, because the destination directory is not properly configured. This may be caused by a problem with the file or directory permissions. More information is available in the system log. "

1. Any idea where the system log is? How do I look at it?

This is a weird error as I should not have any file or directory permission issues. My directory permission is set to 750 throughout the site and the files permission is set to 640 throughout the site, except for the "files" directory in the /sites/default directory, which is set to 650. I tested other permission levels including 777, 655, 666 and the respose from Drupal is rather peculier..... I get an access denied error to the site when I increase the permission level....I would have thought that I could do more with less security when I set the permission to 777 but instead Drupal shuts the site down.

2. Any ideas why this happens?

I also ran the "rebuild permissions" tool found in Admin > Reports > Status Reports >Node Access Permission .... thinking it would set up everything so the site would work but it did not do anything to the permission settings of the directories or files. ... Funny thing... The Node Access Permission is listed as disabled in the status report. I am not sure what this means.

3. Any idea how Node Access Permission works?
4. When and How would I enable Node Access Permission?

After running the "Rebuild Permissions" I got a new error, which I do not understand as well.

"Warning. file_put_contents(public:///.htaccess): failed to open stream: "DrupalPublicStreamWrapper::stream_open" call failed in file_create_htaccess()(line 507 of /home/mywebsite/includes/file.inc).

6. Any idea what this warning message is about?
6. How do I set up Drupal so it actually works.

By the way, this is a fresh install and I had no problems following the instructions. Everything seamed to load well on my Ubuntu Linux 10.10 server.

Thanks

Spineless

Comments

christopher james francis rodgers’s picture

Drupal 7 Module And Theme Installation Error While Trying To "Install From A URL" While Using
"Install new module" Page.

=== My Solution ===
.
The solution for me was simply..
.
Go to 'Configuration' > 'Media' > 'File System'
([*root*]/admin/config/media/file-system)
and change the 'Temporary directory' from
/tmp
to
tmp

======================

.2011.07.08 - I updated this post to refine the work-around solution.

See http://drupal.org/node/1106492 for all the details.


All the best; intended.
-Chris (great-grandpa.com)
___
"The number one stated objective for Drupal is improving usability." ~Dries Buytaert *

christopher james francis rodgers’s picture

I corrected my post above to reflect a better solution.

The details are at http://drupal.org/node/1106492


All the best; intended.
-Chris (great-grandpa.com)
___
"The number one stated objective for Drupal is improving usability." ~Dries Buytaert *