Pls i need help here,
I had a drupal installation running but the server crashed,luckily i was able to back of most of the data.
Now its on a new host, and clean urls isnt working.
Pls i need to get this up ASAP. am on yahoo chat, id == chocolaty4drupal.
pls help!

am running drupal ver 4.7,apache 2, php 5 and mysql 5

i have enabled mod_rewrite , set allowoveride to all and so on.
pls help :-(

Comments

dafa’s picture

What do you see in apache errorlog for the site? It usually saids whats wrong.

--
dafa

chocolaty’s picture

[Sun Jan 21 11:18:11 2007] [error] [client 127.0.0.1] File does not exist: C:/Apache2/Apache2/htdocs/drupal/nowshowing, referer: http://localhost/drupal/?q=home
[Sun Jan 21 11:19:14 2007] [alert] [client 127.0.0.1] C:/Apache2/Apache2/htdocs/drupal/files/.htaccess: AllowOverride not allowed here, referer: http://localhost/drupal/?q=admin/settings

chocolaty’s picture

access logs
127.0.0.1 - - [21/Jan/2007:12:34:32 +0100] "GET /drupal/admin/settings HTTP/1.1" 404 303

error logs
[Sun Jan 21 12:34:32 2007] [error] [client 127.0.0.1] File does not exist: C:/Apache2/Apache2/htdocs/drupal/admin, referer: http://localhost/drupal/?q=admin/settings

http.conf
<Directory "C:/Apache2/Apache2/htdocs/drupal/">
Options FollowSymLinks
 #AllowOverride All
 RewriteEngine On
 RewriteBase /
 </Directory>


htaccess
#<IfModule mod_rewrite.c>
RewriteEngine on
AllowOverride All
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ /index.php?q=$1 [L,QSA]
#</IfModule>

my clean url settings radio buttons are not clickable/greyed out.
when i run the test is give me a page not found error .

victorkane’s picture

If by any chance you are using ubuntu, check out my recomendations here (may help for Debian, or simply for Apache 2 questions). See http://awebfactory.com.ar/node/101 (Clean URL's on Dapper)

Also, try remming out the "Rewrite Base /"

(start from a fresh .htaccess from Drupal distribution, follow Apache configurations first, then alter .htaccess if you really need to)

Victor Kane
http://awebfactory.com.ar

dafa’s picture

Seems like no rewriting is done.

1. Just checking - Does your htaccess-file have a dot in front of the filename? It should be named .htaccess.

2. Your .htaccess does not look like the one I have in my drupal5 homepage... Have you written your own? What happens if you use the one from the drupal-package?

--
dafa

chocolaty’s picture

i first run a test on my system before ftp to my server.
on my system i run a winxp o/s on the server i run a linu fedora.(both not working)

i notice in http.conf there is a default directory setting set to allowoverride none
e.g

<Directory "C:/Apache2/Apache2/htdocs"> 
allowoverride none

but when i change it to allowoverride all
and also add
Allowoverride all in htaccess

, it gives an error in log
[Sun Jan 21 14:09:10 2007] [alert] [client 127.0.0.1] C:/Apache2/Apache2/htdocs/drupal/files/.htaccess: AllowOverride not allowed here, referer: http://localhost/drupal/?q=admin/settings

but when i comment it out in htaccess the error disappears.
but still no clean url, pls help am still on yahoo chat

p.s there is a . prefix in my htaccess file

chocolaty’s picture

pls am running out of time.
pls can someone help, i need to update my site and have it running soonest.\
my job is on the line here.
pls can i get a number or a chat id,pls
or can someone pls buzz me on my chat, am in despair.
yahoo id : chocolaty4drupal@yahoo.com

dafa’s picture

1. Try writing some unparsable jibberish in your .htaccess - And then reload the page and see if you get a Server Error from Apache. This way we can check if the .htaccess file is even loaded.

2. Is you site located directly under C:/Apache2/Apache2/htdocs? What is the path where the drupal files lies?

3. Is it under a apache virtual site?

--
dafa

chocolaty’s picture

i tried that and i noticed some images disappeared and the jibberish was reported in apache error logs.
yes my drupal installation is in c:/apache2/apache2/htdocs but it isnt under any virtual site.
:-? ???

dafa’s picture

So we got proof that the .htaccess actually is loaded? Apache showed a Server Error page, when jibberish was in the .htaccess? Apache usually stops loading the page and shows a Server Error, when .htaccess is misconfigured.

Did you try copying a .htaccess from a fresh drupal installation?

--
dafa

chocolaty’s picture

no server error was recorded,the page loaded normally.
just noticed a log error, of mispelled variable or wrong syntax in apache/errorlog.
i did upload a fresh new .htaccess from drupal 4.7.5

dafa’s picture

So maybe the .htaccess is not even loaded...?

The .htaccess doesn't have a hidden .txt after it, does it? This could happen if you've edited it on a windows machine...

Have you searched apache conf for directives, that could override the AllowOverride line in your path?

Have you got a AccessFileName .htaccess line in apache conf?

--
dafa

chocolaty’s picture

hey are do u use irc chat am on it right now, cud make it easier?
Anyways i've checked and htaccess doesnot have a .txt after it.

AccessFileName .htaccess is in my httpd.conf and

Order allow,deny
Deny from all

I have allowoveride all set in and

i have pasted my http.conf in http://drupal.pastebin.us/12184
and my htaccess in http://drupal.pastebin.us/12197

chocolaty’s picture

i tried that and i noticed some images disappeared and the jibberish was reported in apache error logs.
yes my drupal installation is in c:/apache2/apache2/htdocs but it isnt under any virtual site.
:-? ???

chocolaty’s picture

i tried that and i noticed some images disappeared and the jibberish was reported in apache error logs.
yes my drupal installation is in c:/apache2/apache2/htdocs but it isnt under any virtual site.
:-? ???