I just installed the module and get this error message:

Unable to load site map. Make sure your temporary directory exists and is writable by Drupal.

I read the documentaion and other postings in this forum. What am I missing?

Comments

cedricstier’s picture

Component: Documentation » Code
Priority: Normal » Critical

Could somebody please look into this? I assume I have to create directory, or change permissions? I ma not sure where to find this folder or what exact permissions to set.

somethingorother’s picture

I'm having the same problem. I'm sure it's a simple fix, but I just don't know what it is. When I go to /sitemap.xml, I get the following error:

XML Parsing Error: no element found
Location: http://www.mysite.com/sitemap.xml
Line Number 1, Column 1:

When I hit the back button, Drupal gives me this message:

Unable to load site map. Make sure your temporary directory exists and is writable by Drupal.

Any help would be appreciated.

Thanks.

m3avrck’s picture

You need to go to admin > site configuration > file settings to properly setup your files and tmp directories.

somethingorother’s picture

Just to be clear, the files and tmp directories should be in the home folder, correct? I've got both set up with chmod 777. Just to be careful, I also put a tmp directory inside the files directory. I still get the same errors. I'm at a loss.

ethang’s picture

See http://drupal.org/node/144166

...using 'tmp' instead of '/tmp' as the temporary directory. Looks like it has something to do with how the absolute path is translated...

darren oh’s picture

Status: Active » Closed (duplicate)
eljustino’s picture

I think part of the problem is the fact that it's trying to use the system's default temp directory to create the drupal_gsitemap/ directory.

For instance, in my case, my site is hosted by hostmonster.com. Obviously, as a webhosting company, they have many other users. Since one of those other users apparently also uses Drupal and the gsitemap module, that /tmp/drupal_gsitemap directory was already created with the other user as the owner. I don't have write permissions to that directory as a result, so it can't create the /tmp/drupal_gsitemap/www.nerdliness.com directory it wants to use.

Would be great if this module were written to use a temp directory relative to the site instead so people in my situation can always use it right out of the box.

Thanks.

Justin

fmmribeiro’s picture

i have the same problem to .
All my 5 web sites fail to use sitemap (drupal 5.1).
-- it creates a folder /tmp/drupal_gsitemap/ and nothing else

The one that uses drupal 4.7 works fine.

vigoncas’s picture

The problem is PHP safe_mode.

You can see the thread here

http://drupal.org/node/144166

:-)

Laurel Papworth’s picture

I changed admin->site config ->file system from /tmp to straight tmp (no slash). Worked fine.

Amix’s picture

Assigned: Unassigned » Amix
Status: Closed (duplicate) » Fixed

Laurel Papworth solution fix's this issue.

change admin->site config ->file system from /tmp to straight tmp (no slash).

Anonymous’s picture

Status: Fixed » Closed (fixed)

Automatically closed -- issue fixed for two weeks with no activity.