Closed (fixed)
Project:
Google Sitemap
Version:
5.x-1.10
Component:
Code
Priority:
Critical
Category:
Support request
Assigned:
Reporter:
Created:
25 May 2007 at 00:43 UTC
Updated:
28 Oct 2008 at 08:14 UTC
I just installed the module and get this error message:
Unable to load site map. Make sure your temporary directory exists and is writable by Drupal.
I read the documentaion and other postings in this forum. What am I missing?
Comments
Comment #1
cedricstier commentedCould somebody please look into this? I assume I have to create directory, or change permissions? I ma not sure where to find this folder or what exact permissions to set.
Comment #2
somethingorother commentedI'm having the same problem. I'm sure it's a simple fix, but I just don't know what it is. When I go to /sitemap.xml, I get the following error:
When I hit the back button, Drupal gives me this message:
Any help would be appreciated.
Thanks.
Comment #3
m3avrck commentedYou need to go to admin > site configuration > file settings to properly setup your files and tmp directories.
Comment #4
somethingorother commentedJust to be clear, the files and tmp directories should be in the home folder, correct? I've got both set up with chmod 777. Just to be careful, I also put a tmp directory inside the files directory. I still get the same errors. I'm at a loss.
Comment #5
ethang commentedSee http://drupal.org/node/144166
Comment #6
darren ohComment #7
eljustino commentedI think part of the problem is the fact that it's trying to use the system's default temp directory to create the drupal_gsitemap/ directory.
For instance, in my case, my site is hosted by hostmonster.com. Obviously, as a webhosting company, they have many other users. Since one of those other users apparently also uses Drupal and the gsitemap module, that /tmp/drupal_gsitemap directory was already created with the other user as the owner. I don't have write permissions to that directory as a result, so it can't create the /tmp/drupal_gsitemap/www.nerdliness.com directory it wants to use.
Would be great if this module were written to use a temp directory relative to the site instead so people in my situation can always use it right out of the box.
Thanks.
Justin
Comment #8
fmmribeiro commentedi have the same problem to .
All my 5 web sites fail to use sitemap (drupal 5.1).
-- it creates a folder /tmp/drupal_gsitemap/ and nothing else
The one that uses drupal 4.7 works fine.
Comment #9
vigoncas commentedThe problem is PHP safe_mode.
You can see the thread here
http://drupal.org/node/144166
:-)
Comment #10
Laurel Papworth commentedI changed admin->site config ->file system from /tmp to straight tmp (no slash). Worked fine.
Comment #11
Amix commentedLaurel Papworth solution fix's this issue.
change admin->site config ->file system from /tmp to straight tmp (no slash).
Comment #12
Anonymous (not verified) commentedAutomatically closed -- issue fixed for two weeks with no activity.