When I go to the apps system menu I receive this:

There was the following error - Manifest: http://url/~njumccom/?q=profiles/openchurch/apps.js Not Found

I find this odd because I can see the file on the server and I'm able to load it manually by going to: There was the following error - Manifest: http://url/~njumccom/profiles/openchurch/apps.js

Comments

drupalninja99’s picture

Status: Active » Needs work

I probably need to add a documentation page. The openchurch installation doesn't expect to be in a subdirectory. You will need like a vhost so that openchurch runs off of the root directory.

dmullens’s picture

Right now I have this on a test account that I will point my domain to after I get everything setup. So you are saying if I point my domain (njumc.com) to this account, so the URL is http://njumc.com instead of http://173.254.28.25/~njumccom/ it should work?

I'll have to see if I have an old domain I can use to do this....if you believe that is the problem. I can't move the njumc.com over yet because we are using it to host our production website.

Code Monkey’s picture

Could you create a subdomain, such as as oc.njumc.com, to try it out? That should resolve the root directory issue for testing purposes.

drupalninja99’s picture

Ya I think you will have multiple issues if you try to run in a subdirectory. One thing too that you could try is adding your base url to your settings.php

$base_url = 'http://www.example.com'; // NO trailing slash!

In that way drupal can be more aware of what the root base url is. That being said it is odd that the app.js isn't loading since I am not hardcoding the path, but rather using the url() function.

drupalninja99’s picture

Status: Needs work » Postponed (maintainer needs more info)
sugens’s picture

I get this same error using a subdirectory on loaclhost (i.e. http://localhost/openchurchd7).

Tried your suggestion of adding $base_url = 'http://localhost/openchurchd7'; // NO trailing slash! to settings.php but still get the same error.

drupalninja99’s picture

Ya so the easiest thing to do is set up a virtual host like 'openchurchd7.local' is how I usually do it.

drupalninja99’s picture

Status: Postponed (maintainer needs more info) » Closed (works as designed)

closing

willr’s picture

I ran into this same problem and tried all the suggestions without success.

To resolve the issue, I modified the openchurch.info file, and changed the line from 'files[] = openchurch.profile' to 'files[] = profile' and that resolved the issue.

lennysh’s picture

I'm having the exact same issue, but none of the suggestions here are working for me... The message I'm getting is below:

There was the following error - Manifest: http://www.whiteoakfwc.com/?q=profiles/openchurch/apps.js Not Found

The file is definitely there... Could it be a permissions thing? Or could the file be corrupted? This is a new install of openchurch-7.x-1.11-beta7-core