Running Drupal 6.2, Link 6.x-2.1-beta4. I have a content type that includes a Link field. When editing or creating a node of that type, I get upon submission: "user warning: Unknown column 'field_website_1_url' in 'field list' query: UPDATE content_type_store SET vid = 2352"

Sincerely,
Jason

Comments

quicksketch’s picture

This seems like a problem particular to your installation. I'm not getting that in my sandboxes, nor has anyone confirmed the problem. If it affected everyone there'd be a lot more requests that this. Perhaps try deleting the link field then adding it again? It seems like your database schema is not correct somehow (which is handled by CCK, not link module).

webchick’s picture

Status: Active » Postponed (maintainer needs more info)
quicksketch’s picture

Status: Postponed (maintainer needs more info) » Closed (fixed)

Closing after 2 weeks with no activity.

seanr’s picture

Status: Closed (fixed) » Active

The module is not creating the field column when a link field is added because you've set it to be of type varchar(1024). That is invalid as varchar can only be 255 or shorter. Use text or blob instead. Version 5.x-2.3 is what killed it.

seanr’s picture

Specifically: #141925. Increasing length of url and title fields to 1024 characters.

tekmo’s picture

I get this same error... 5.7 installation. Happens when I try to create the field with the Link Field Type

* user warning: Column length too big for column 'field_group_website_url' (max = 255); use BLOB or TEXT instead query: ALTER TABLE content_type_groups ADD COLUMN field_group_website_url varchar(1024) NOT NULL default '' in /home/mysite/public_html/includes/database.mysql.inc on line 172.

* user warning: Column length too big for column 'field_group_website_title' (max = 255); use BLOB or TEXT instead query: ALTER TABLE content_type_groups ADD COLUMN field_group_website_title varchar(1024) NOT NULL default '' in /home/mysite/public_html/includes/database.mysql.inc on line 172.

Anonymous’s picture

Same error:

    * user warning: Unknown column 'field_ticket_link_url' in 'field list' query: UPDATE content_type_production SET field_ticket_link_url = 'http://testurl.com', field_ticket_link_title = '', field_ticket_link_attributes = 'N;' WHERE vid = 98 AND nid = 98 in /home/mysite/public_html/drupal/includes/database.mysql.inc on line 172.
    * user warning: Unknown column 'field_ticket_link_url' in 'field list' query: SELECT field_ticket_link_url AS url, field_ticket_link_title AS title, field_ticket_link_attributes AS attributes FROM content_type_production WHERE vid = 98 LIMIT 0, 1 in /home/mysite/public_html/drupal/includes/database.mysql.inc on line 172.

Drupal 5.8, Link 5.x-2.3

Please help,
txcrew

a2vicki’s picture

same error too

subir_ghosh’s picture

Version: 6.x-2.1-beta4 » 5.x-2.3

Same error here as well:

Unknown column 'field_internet_links_02_url' in 'field list' query: SELECT field_internet_links_02_url AS url, field_internet_links_02_title AS title, field_internet_links_02_attributes AS attributes FROM content_type_article WHERE vid = 27 LIMIT 0, 1 in /home/mysite/public_html/includes/database.mysql.inc on line 172.

Bobuido’s picture

Me too - Subscribing

user warning: Column length too big for column (max = 255); use BLOB or TEXT instead''

I don't see how it's a definition problem as I exported the custom content type from one Drupal to another

Link 2.3

quicksketch’s picture

Status: Active » Closed (duplicate)