Subject says it all. Lots of Googling and no solutions. Every response appears to be to not set session.save_handler to user in php.ini, or ignores the fact that drupal needs it set to user.

System:
IBM server, 2xPIII-1GHz, 1GB RAM
FreeBSD 5.4-Stable
apache-2.0.54_2
mod_php4-4.4.0,1
php4-mysql-4.4.0
php4-session-4.4.0

Hitting the website /drupal directory inevitably results in:

[error] [client 10.0.0.65] PHP Fatal error: Unknown(): Failed to initialize storage module: user (path: /tmp) in Unknown on line 0

which is NOT set in the global php.ini, although session/save_handler: user is set, so I'm assuming that's the default (/tmp)

Fighting this for goin on 8 hours at this point, getting quite old.

I'm unable to upgrade to try php5, as I also need to run an earler version of xoops on this box for some dev work.

This really needs a resoltuion that is in big bold writing in a FAQ somewhere on both PHP and Drupal sites.

Anyone actually have this combination working, hopefully from current BSD Ports system?

Comments

wegster’s picture

Hmm, no way to edit existing posts either? :-(

wegster’s picture

Ran across a few other issues as well, primarily $base in settings.php (in drupal tree), which was odd, as the site would work, but all the urls were being rewritted hokey, pointing to http://site/?q=N etc and thus not working. Fixed $base and things are now working. I added the start of a FreeBSD specific install page onto the doc site.

futurahost’s picture

Hello

Strong workaround is:

Edit your php.ini this way:
auto_prepend_file = /usr/local/lib/php.ini.prepend

On your /usr/local/lib/php.ini.prepend file put this:
<? session_module_name("files"); ?>

Of course, you can place your prepended file wherever you like, as long as you state it correctly on your auto_prepend_file directive of php.ini

Regards

Agustín Povarchik
FuturaHost.Com