By HNH992 on
Hi
I configured my site in localhost and when was everything fine and ready to upload to my hosting, i uploaded the files to my site.
but there a problem
status report says: "The image module's image directory images is missing."
and I went to "sites\default\files" but i saw images folder
and I allowed read/write access to the "files" directory (chmod 777), "images" directory and "images\temp" directory.
and i searched in forum and i found those topics:
http://drupal.org/node/299809
http://drupal.org/node/245971
and i did exactly what they wrote.
but the problem didn't slove.
please help me.
Comments
I went to File System and i
I went to File System and i changed Temporary Directory.
and the message gone.
but there another problem:
I can't upload images
when i try to upload image i get this message:
warning: move_uploaded_file() [function.move-uploaded-file]: SAFE MODE Restriction in effect. The script whose uid/gid is 23002/23002 is not allowed to access /*****/*****/sub009/sc32050-AYNZ/*****/sites/default/files/temp owned by uid/gid 99/99 in /*****/*****/sub009/sc32050-AYNZ/*****/includes/file.inc on line 572.
File upload error. Could not move uploaded file.
I allowed read/write access to the "temp" directory in "files" directory (chmod 777).
but i still get the message.
i fixed it. i made "temp"
i fixed it.
i made "temp" folder. just like this: www.site.com/temp
I allowed read/write access to the "temp" directory.
and i made .htaccess in "temp" directory.
and i went to File System and changed Temporary directory.
now i can upload images without problems.
thank you all.