Hi,

I want to install Drupal on my server which is under Centos 5.0. But the installation do not pass the step "Database configuration". I fill in the different fields (Database name, username, password) and then click on "Save and continue" but the page reloads again without any error notification.
Before this problem, I had an error with the mysql.sock which was not on the right place but I fixed it.
To be complete, I checked with another username and it gave me the appropriate error ("Access denied for user"), so the mysqld is running well on the right host.
Thanks in advance for answering.

Comments

FanisTsiros’s picture

Hi
Have a look here http://drupal.org/node/318435

so create a copy of your sites/default/default.settings.php and name this file sites/default/settings.php

ReliabilityConsistencyFeedback

nyirocsaba’s picture

Same error, 6.5v worked perfectly, the configuration did not changed, and 6.6 doesn't want to pass the "Database configuration" step. Any idea?
-------------------------------------------------
Solved, sorry!

dawam’s picture

Yap... had the same problem, it seems that both file default.settings.php and settings.php must be present on the sites/default/ directory.

Took some time for me to discover this.

nyirocsaba’s picture

Yep