Closed (fixed)
Project:
XML sitemap
Version:
5.x-1.6
Component:
Code
Priority:
Normal
Category:
Bug report
Assigned:
Unassigned
Reporter:
Created:
30 Apr 2009 at 20:40 UTC
Updated:
16 Dec 2010 at 19:42 UTC
Jump to comment: Most recent
I could not access the sitemap page:
https://mydomain/index.php?q=sitemap.xml
Instead I get Content Encoding Error message:
The page you are trying to view cannot be shown because it uses an invalid or unsupported form of compression.
This problem appeared after moving to secure website.
There is also other issue reported in Google webmaster tool about the sitemap: Leading whitespace
We've detected that your Sitemap file begins with whitespace. We've accepted the file, but you may want to remove the whitespace so that the file adheres to the XML standard.
Comments
Comment #1
wisdom commentedThe title does not fit it should be for the second issue. Please consider the title as:
Content Encoding Error is generated when trying to access
https://mydomain/sitemap.xml.
Comment #2
avpadernoComment #3
dave reidI bet that you are getting the encoding error because of the extra whitespace since it's unexpected for a cached file. The poster in the other issue that you refer to had a mistake in one of his modules where he had an extra space before his PHP tags, which ended up in the eventual output. Can you verify that you are still having the problem?
Comment #4
wisdom commentedThere are a number of custom modules and I will look at the white space in the php closing tag. Just I wonder how such kind of things affect the sitemap.
Comment #5
wisdom commentedOne of the custom module start like
1.
2.<?php
// $Id: balance.module,v 1.8 2007/03/07 05:38:18 neclimdul Exp $
changing it to
1.<?php
// $Id: balance.module,v 1.8 2007/03/07 05:38:18 neclimdul Exp $
solved the problem.
Thanks David Reid for your help.
Comment #6
dave reidGreat that you found the problem! Things like that are always tricky to find since PHP is not very helpful. :/ Marking as fixed!
Comment #8
akhil commentedI am also getting the same error and since there are lots of custom modules installed, I am not able find out where the extra space is. Is there a way to find out from where this is happening?
Comment #9
Anonymous (not verified) commentedI came up with
grep '^<?php' . -rn | grep -v ':1:'which will give you files with <?php not on line 1.Comment #10
Anonymous (not verified) commentedComment #12
Branjawn commentedGuess I'm screwed. I have no idea how to search for that.