I'm making a slideshow from uploaded images but when I choose slideshow or any other option as a style views gives me these errors. I don't know php at all so this means nothing to me.

* warning: Parameter 3 to views_ui_build_form_state() expected to be a reference, value given in C:\xampp\htdocs\uys and white\sites\all\modules\views\includes\admin.inc on line 1606.
* warning: call_user_func_array() expects parameter 1 to be a valid callback, no array or string given in C:\xampp\htdocs\uys and white\includes\form.inc on line 376.
* warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\uys and white\sites\all\modules\views\includes\admin.inc on line 1542.
* warning: Attempt to assign property of non-object in C:\xampp\htdocs\uys and white\sites\all\modules\views\includes\admin.inc on line 1613.

I'm using the latest build of drupal 6 (6.19) and all my module are up to date. I had a couple of broblems with image cache on another site using exactly the same setup but no problems with views, so I don't know if it is a problem with the drupal update or what.

Can someone please help me out here.

Thanks

CommentFileSizeAuthor
#9 views-error.png20.42 KBkris_ly

Comments

wind_kind’s picture

Version: 6.x-2.9 » 6.x-2.11
dawehner’s picture

Well the problem is the current xampp version. It uses php 5.3 and quite some contrib modules throws error messages.

wind_kind’s picture

Oh, okay then. I will try and get an update or older version then. Thanks for the help

So this means that if my hosting company upgrades to PHP 5.3 then my site will have the same problems online or is it only a xampp thing?

dawehner’s picture

They are just "warnings" not errors :)

The first error has already another issue. I think this is there for backward compability for php4.

The second one looks bad. Is this really views?

wind_kind’s picture

Yeah it's views I get the errors with if I understand your question correctly. But if it is warnings then why don't I see the slideshow? I upgraded views to alpha 3 and the errors are gone but now I have entirely different issues which I won't go into right now because I would prefer to use a stable release so I will be going back to 2.11 if I can sort this out.

dawehner’s picture

Sure. If you don't know what these kind of error messages are the current alpha/dev is not for you :(

dawehner’s picture

Status: Active » Fixed

So if this fixed.

Status: Fixed » Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

kris_ly’s picture

Version: 6.x-2.11 » 6.x-2.12
Component: Miscellaneous » table style
Assigned: wind_kind » kris_ly
Status: Closed (fixed) » Needs work
StatusFileSize
new20.42 KB

I am using PHP 5.3.0. I tried to change the Basic Setting in Views

The moment I choose
Basic settings ->Style: Views Nivo( I chose Views for Nivo Slider)

It throws an error

warning: Parameter 3 to views_ui_build_form_state() expected to be a reference, value given in C:\wamp\www\drupal-6.20\sites\all\modules\views\includes\admin.inc on line 1606.
warning: call_user_func_array() expects parameter 1 to be a valid callback, no array or string given in C:\wamp\www\drupal-6.20\includes\form.inc on line 378.
warning: Invalid argument supplied for foreach() in C:\wamp\www\drupal-6.20\sites\all\modules\views\includes\admin.inc on line 1542.
warning: Attempt to assign property of non-object in C:\wamp\www\drupal-6.20\sites\all\modules\views\includes\admin.inc on line 1613.

dawehner’s picture

Can you please have a look at views 2.x-dev and see whether it has the error as well?

sdelen’s picture

Same problem here, slideshow is not displayed
Same errors

The errors show up when choosing Style: Slideshow in views

I'm also using xampp
Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1
MySQL-client versie: 5.1.41
PHP uitbreiding: mysqli

I'm using views 6.x-2.12, views slideshow 6.x-2.3, imageapi 6.x-1.10, imagecache 6.x-2.0-beta12

kars-t’s picture

Assigned: kris_ly » Unassigned
Status: Needs work » Fixed

Hi

I am closing this issue to clean up the issue queue. Feel free to reopen the issue if there is new information and the problem still resides. If not please make sure you close your issues that you don't need any more.

Maybe you can get support from the local user group. Please take a look at this list at groups.drupal.org.

Status: Fixed » Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.