-- Patch #1046844 by arthurf. domain_bootstrap() breaks page cache on D7.
-- Patch #624360 by bpresles. Fixes redirection in the event that other modules call url() during node_save().
This release cleans up two bugs that may have hindered use of 7.x.2.7.
Bug fixes
-- When setting a Domain Theme to a "default" color scheme, sites can lose the values for the primary domain, leading to theme errors. #1026346: Domain Theme fail with color module
-- Domain Access can now be disabled when running XMLRPC commands. See #775028: Disable domain access for xmlrpc by brucepearson. Allow DA to be disabled for XMLRPC.
-- Errors in loading the module will now be handled more gracefully, and error messages may be disabled. See #774692: Googlebot visits trigger unique, mysterious errors in DA and MySQL by hawkdrupal. Allow the error sequence to be skipped. Load default domain in event of installation failure to prevent SQL errors.
-- This is a straight port. No new features.
-- Only the core Domain Access module is ready for D7.
-- Changes hook_domainview() to match DBTNG.
-- Deprecates hook_domaingrants() and hook_domainrecords().
Documentation needs an update, too.
This version is for testing only. It is not supported for production.
Developers
After the ALPHA series of ports are finished. There will be an API cleanup period in the BETA branch. Then we will roll the stable 7.x.2.0.
-- Patch #745028: domain_conf_variable_set bug by Docc. Corrects the save function in domain_conf_variable_set(), which prevented proper saving of some domain-specific variables.
A new release for Drupal 6, after I said we were feature frozen, but some cool new stuff popped up. We also worked to quash some nasty bugs and become more drush-friendly.
This release requires that you run update.php or a menu rebuild.
New Features
-- Domain Settings module. Exposes most configuration forms to domain-sensitive settings. Requires Domain Conf, and should make adding domain-specific settings for contributed modules much easier.
This is the final release in the Drupal 6 cycle. Consider the module feature complete for Drupal 6. Any additional features will need to be handled by extension modules.
The Drupal 6 version is now in bugfix only mode, so we can move to Drupal 7.
Upgrade Notes
-- Requires running update.php
-- If you are using the URL Alter module, you must upgrade it to 6.x.1.2 or higher.
-- Domain Views users: We removed a hack that applied domain filters on all views. There is a Drupal core issue for the best way to resolve duplicate items in View when node access modules are present.
You may need to edit your Views to use 'distinct'. You may also need to adjust the filters on your View.
There is nothing that Domain Access can do to fix this problem. For more information, see #284392: db_rewrite_sql causing issues with DISTINCT and assist with the patch there.
-- There are some new permissions and settings. Please see the documentation below, and in README.txt. In particular, the change in #615294: Force node access rules on admins will allow you to preview your site as user 1 and see what normal site visitors will see.