Steps to reproduce:
- Create a new pipeline
- Go to the "rename" tab, and try to assign a different name to it
- Doesn't work: "Unable to load pipeline"
I guess this is because it tries to fuzz with the permanent pipeline store (in the database) even though it doesn't need to. Haven't investigated, but it can't be that difficult. Anyone feel like providing a patch?
Reasons:
1. It's confusing: Workflow is a loaded word; and these features are paltry compared to modules like Workflow or Rules.
2. It's repetitive/unnecessary: It doesn't make much sense to have a collapsed set of configurations with only one group of configurations.
3. It's out of place: Workflows can make use of more than just node submissions.