Do I have to manually code template files every time I create a new content type?

Hi,

I have been developing and maintaining a Drupal website for about a year now..one thing I have become accustomed to but has started to annoy me is the fact that if I create or even edit a new content type, nothing happens until I go into the template files, and override the templates by creating a new template file for the content type and manually editing the file so that my user defined fields are rendered using the file.

e.g.

<?php print render($content['<<custom field name>>']);?>

Drupal 7 web directory with nginx and Solr

Would really be glad to hear your opinions about this web directory - webindirectory.com . It's a Drupal 7 + Solr on nginx. And if some one would like to register and submit a website there - it would be really really Awesome! ;)

Commerce Coupon Rules ?

Hi all,

Ok, so I really need some help with the commerce coupon module.
I've been trying and trying to play around with the rules to get this working but getting nowhere.

Could someone please give me an idiots set by step on getting coupons to work.

I am currently trying to get a 20% discount to my mid week classes but need to fully understand them as I hope to use a lot with various types.

I have searched and searched but can't find any good documentation to tell me where I'm going wrong.

Many Thanks in advance

Very random 500 Internal server error

Hi

Drupal site gives 500 Internal server error at very random moments.
Is there some way how to track it down?

Each time when 500 strikes, error_log will have these entries:
------------
ka.test.com [Sun Aug 26 00:47:45 2012] [error] [client 86.15.149.1] mod_zfpm(2293)-14A1809F: partial FastCGI response: socket closed before receiving FCGI_END_REQUEST record: num_prev_requests=5 num_bytes_read=111448 (fastcgi.c:1068), referer: http://ka.test.com/en/test

Security issue and how I fixed it: website path redirected to Conduit search page

I was going to post about a security issue I ran into but I figured it out, so hopefully this will help others.

This is a good reminder to all that sometimes hackers don't just attack the website framework and server, but they also leave open holes on the computer for third parties to manipulate. Lesson learned. Don't install upgrades or download software even if it's from a trusted source unless one knows exactly what is being installed (i.e. Adobe Flash update automatically installs McAfee, Nchsoftware Videopad installs NCH/Conduit toolbar).

Problem:

I recently put up my website a month ago. In this example I used Firefox to test my site. I noticed that my taxonomy path from my website points to a website (nchsoftware) that kind of looks like a search engine. The weird thing is that taxonomy/term/foo was fine.

See screenshot if you're interested: http://i.imgur.com/F6CCE.jpg

Security Steps:

1) I don't have redirects for that path anywhere in Drupal or on my server.
2) I have the Path Access module installed that only allows a few paths that does not include taxonomy, but somehow the taxonomy path still shows up and doesn't show access denied.
3) I have a robot.txt that doesn't allow search engines to look in certain areas.
4) I have a spam filter and blacklisted words.
5) My forms only allow plain text with limited HTML.

Solution Steps:

Node template based on a view displaying the node

I have a content type called film which has a template called node--film.tpl.php. Now I need to display a list of films in a new view but I need another template in that case. Is that possible?

Pages

Subscribe with RSS Subscribe to RSS - Drupal 7.x