problems with AJAX, 500 errors with PHP upgrade from 5.3 to 5.4

I'm on a shared service provider (Digital Pacific) who recently upgraded their PHP environment from 5.3 to 5.4.

Ever since the upgrade I've had persistent 500 errors with my site.

There are a whole range of triggers for this - the main ones being:

provision-save core dumps on loops

Way to go, PHP. I have no idea why it does that

Changes to the User Permissions Not saving.

Every time I go to Save User Permissions, the changes just disappear!
I set my preferred settings throughout my 5 or 6 roles and when I'm done I go to the bottom and Click 'Save Permissions'. A similar problem occurs with my Menus. Where when I set them and click Save the changes disappear
I need to know what I should do. This is a site that is due to release in 10 days!

fatal error

i have passed all installation instruction

after applying patch:
Notice: Array to string conversion in /usr/home/www.forexchat.ru/public_html1/includes/bootstrap.inc on line 396
z
Warning: require_once(z) [function.require-once]: failed to open stream: No such file or directory in /usr/home/www.domain.com/public_html1/includes/bootstrap.inc on line 932

Subscribe with RSS Subscribe to RSS - Suhosin