I've just upgraded my site to the latest 6.x-2.2 release of Wysiwyg, and also took the opportunity to upgrade the ckeditor library from 3.0 to 3.5. I discovered that the "Enable resizing button" option is now ignored, and a resizing button is already present on text areas, regardless of how this option is configured.

I've tracked this down to a chage in the ckeditor library that occured somtime between the 3.0 and 3.5 releases. Previous, it checked this option (in ckeditor/_source/plugins/resize/plugin.js) with the following line of code:
if ( config.resize_enabled )
But now, it uses
if ( config.resize_enabled !== false )

Unfortunately, the Drupal module passes the value of the configuration setting to ckeditor as an integer, and not a boolean, and so this test now always passes, meaning that the resize button is always present.

The attached patch (against 6.x-2.2) fixes this problem by forcing the Drupal module to pass a boolean value to the ckeditor library.

Comments

Version:6.x-2.2» 7.x-2.x-dev
StatusFileSize
new606 bytes

Thanks!

+++ wysiwyg/editors/ckeditor.inc 2010-12-25 00:12:15.000000000 +0000
@@ -184,7 +184,8 @@
+    $settings['resize_enabled'] = ($config['resizing'] ? true : false);

The coding standards say to use FALSE/TRUE, but we just need a bool cast here.

Powered by Dreditor.

Can you verify this still works for you with this patch?

Status:Needs review» Fixed
StatusFileSize
new1.32 KB

Thanks for reporting, reviewing, and testing! Committed to attached patch.

A new development snapshot will be available within the next 12 hours. This improvement will be available in the next official release.

Yes, the modified patch still works fine for me.

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

subscribe

@animelion, this issue has been fixed and the patch is now in the latest releases so there will be no further updates here. If you're still seeing the problem in the latest release, please change the status back to active and provide as much information about your setup as you can.

Thanks TwoD, I'm not experiencing this problem, I was just subscribing to a bunch of threads I saw. I didn't realize this patch had already been committed.