It seems token 6.x-1.16 is not (yet) released. Do I really need to a token dev version to use the new analytics module?

Cheers, Fons.

Comments

- subscribing -

I see that token 1.15's release date is december - 25. Is that version the stable version from "mid-December DEV" version ?

I can't find a 1.16 yet.

Category:bug» support
Status:Active» Fixed

You need latest DEV or you will have issues if you use custom variables. GA requires some features that are not yet available in any final release. Token 6.16 has not released yet.

If you are not using custom variables you do not need the latest token DEV. Than you may run with other versions. But this have never been tested...

Title:Why is token 6.x-1.16 (or latest DEV) and 7.x-1.0-beta1 required?Why is 6.x-1.16 (or latest DEV) and 7.x-1.x required?

6.x-1.16 (or currently latest DEV):

7.x-1.0-beta1:

Title:Is token 6.x-1.16 really needed?Why is token 6.x-1.16 (or latest DEV) and 7.x-1.0-beta1 required?

subscribing

I don't think it's a "best practice" to release a stable version of Google Analytics, which depends on a unstable version of Token ...

Can you clarify this sentence.

If you are not using custom variables you do not need the latest token DEV. Than you may run with other versions.

Thanks

Subscribing.

I have asked Dave for a new D6 release and he pointed me to review patches... I don't like my decission very much, but I don't like to wait one year until I'm able to release only for tokens. Ask in the token queue for a new release, please. In general token works fine, but older versions have a few issues I would not accept myself.

Part of the confusion is the way Drupal's Available Updates system notifies us that we are running an unsupported version of Google Analytics. We are getting notifications about it this in our admin pages. Then we read the release notes for GA 6.x-3.1, and those tell us that the recommended version of GA requires an unreleased version of Token.

I agree that you shouldn't have to wait to release GA, but since Token is a dependency, the release of the 6.x-3.1 GA module raises a valid question.

How do I know that the -dev version of Token won't break my site?

If you are not using custom variables you do not need the latest token DEV. Than you may run with other versions. But this have never been tested...

On my sites that aren't using custom variables, I'm still not sure I should use GA 6.x-3.1 with other versions of Token. As the comment above points out, "this has never been tested". Or have I misunderstood that comment?

So, my workaround is to use the Available Updates advanced settings (http://drupal.org/project/update_advanced) configuration to ignore GA 6.x-3.1 (thus squelching the update notification). Is this the desired behavior?

A release of Token 6.16 has been requested here:
http://drupal.org/node/1036066

Would probably have been not that confusing when this change would have happend in a ... 4.0 branch. Can't you simply mark the 3.0 as recommended and the 3.1 as "also available" ? Then we should get green screens on the update page but it would still show up under "also available" on the update screen.

Besides that i agree that its pretty bad manner to release a stable version of a module that requires and unstable dev version of another module. Thats fine when your module is in dev, alpha, beta or RC, but not when its marked as stable.

Title:Why is 6.x-1.16 (or latest DEV) and 7.x-1.x required?Why is token 6.x-1.16 (or latest DEV) and 7.x-1.0-beta1 required?

I have not seen any issues with token DEV myself. Aside - it's only token replacement. If something goes wrong, just downgrade - who cares - there are no DB changes, no tables, just downgrade and you should be done.

I concur with Michael Curry. A major part of the issue here was the decision to unpublish Google Analytics 6.x-2.3, which means that installs happily running that version until now report they are running an unsupported version, but meanwhile an unreleased version of Token is a dependency. Installing a -dev version of a dependent module is not trivial, as it then requires intervention to upgrade to the stable version later, or upgrades will continue to follow the -dev path.

The release notes for GA 6.x-2.3 state:

NOTE: It's recommended to use the Google Analytics module v3.0. There is no reason to stay away from 3.x, except your are running Ubercart that hasn't been upgraded yet to the latest tracker API.

In my view, there is another obvious reason to stay away from 3.x, and until that is resolved, I suggest that 6.x-2.3 should be republished.

Status:Fixed» Active

Title:Why is token 6.x-1.16 (or latest DEV) and 7.x-1.0-beta1 required?Why is token 6.x-1.16 (or latest DEV) and 7.x-1.0-beta1 required? Answer in #3
Status:Active» Fixed

Ubercart should also publish a new release, too.

There are really good reasons to upgrade GA to 3.1 as deprecated Google API functions may break tracking in future. They are partly deprecated for over 1 year.

Everything has been answered in comment #3. Feel free to use outdated GA module versions that may break your tracking soon. It's Your responsibility.

And I unpublished 2.3 for the reason that the buggy update status module does NOT show 3.1 as recommended. See #208766: Latest release from maintainer's recommended branch called "Also available", not "Recommended"

Status:Fixed» Active

Doesn't really change the fact that a release based on an unstable dependency is by definition not a stable release.

Subscribing, and +1 to republishing 2.3 (or somehow coming up with a release that is stable by more than just name alone).

Status:Active» Fixed

Sorry, didn't mean to mark as active -- just hadn't refreshed the form after the change to "fixed," so the dropdown still had "active" as the status. Not going to get into a status war with the maintainer, whether I agree or not.

How about working on the token issues blocking the release... Maybe we have a release within the next two days than...

Or maybe within a week. Or a month. Which would, indeed, circumvent the core problem -- being, again, that a release is marked as "stable" when it is not.

Just as I wasn't about to argue on whether this should be "fixed" versus "active" -- it's pretty presumptuous to be telling the token maintainers when they should and shouldn't be rolling a release. They say they want to backport all 7.x-1.x fixes to 6.x before rolling a new release (which makes sense); that's their call. And I seriously doubt that will be two days.

Again, counting on a new token release means circumventing, not fixing, the current problem. There is currently no published, stable 6.x version of Google Analytics -- though one is marked as such. *That* is the problem.

I agree. Revert to 3.0 which is stable and published !

Although some users noticed that token 6.16 isn't released yet, some users might have already updated to 3.1
If token takes a long time to release, I think writing a proper readme.txt is a good idea.

Again, You can use older token D6 versions (1.14+), but I highly recommend latest DEV or 1.16+. You can also use older GA versions, but I don't support them any longer as I know what code has been changed. And the dependency with token is more or less optional and a very buggy token module don't make a GA release unstable.

I also know why I hate to depend on other modules however helpful they are... You all show me that I'm correct. :-(

Another vote for a reasonable solution.

I can't believe that the only way to avoid potential problems with Google API deprecations that have been coming for a year now is to upgrade to a version of GA requires an unstable version of Token.

To answer this from #12:

I have not seen any issues with token DEV myself. Aside - it's only token replacement. If something goes wrong, just downgrade - who cares - there are no DB changes, no tables, just downgrade and you should be done.

There are too many variables and potential conflicts in a complex Drupal site as it is to unnecessarily use a dev module. There's a reason it's still dev. To answer "who cares," it does matter on a site where a problem in Token would affect e-mails sent out to customers via Ubercart and URLs generated with pathauto. Downgrading Token would not retroactively fix sent e-mails or automatically fix URLs (or, for that matter, fix links that Google has already indexed or that people have already e-mailed to each other, shared on Facebook, etc).

As for this:

Ubercart should also publish a new release, too.

There are really good reasons to upgrade GA to 3.1 as deprecated Google API functions may break tracking in future. They are partly deprecated for over 1 year.

Everything has been answered in comment #3. Feel free to use outdated GA module versions that may break your tracking soon. It's Your responsibility.

I'm frustrated at reading this thread because I see you assigning responsibility to us GA users and to other modules' developers while declining to present a reasonable course of action.

I see most people want to mark the new GA version from "Recommended" to "Also available".

Well,
these modules are 'contributed modules'. Drupal association doesn't pay money for the module author for releasing a new version.

We should encourage him to keep his work well instead of criticizing him.

I agree that releasing an 'unstable' version(because of another depending module) is not a good idea, but author has done his job. Lets stay calm with the old version of GA till Token's new release comes out.

Title:Why is token 6.x-1.16 (or latest DEV) and 7.x-1.0-beta1 required? Answer in #3Why is token 6.x-1.16 (or latest DEV) recommended and 7.x-1.0-beta1 required? Answer in #3

Changed D6 release notes.

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

subscribing