Hi, I have just upgraded Drupal to the RC2 without any problems and now I'm getting some errors managing a link's field. I don't know if this depend from Link's module but I think it's.

I'm sorry in advance if the problem don't regard this module (and also for my English :) ).

Errors:

Table 'dbname.d1_node_software' doesn't exist query: SELECT field_titolo_url_url AS url, field_titolo_url_title AS title, field_titolo_url_attributes AS attributes FROM d1_node_software WHERE vid = 8 in /home/mysite/public_html/includes/database.mysql.inc on line 167.

Unknown column 'field_titolo_url_url' in 'field list' query: INSERT INTO d1_node_software (field_titolo_url_url, field_titolo_url_title, field_titolo_url_attributes, vid, nid) VALUES ('http://www.mozilla.com', '', '', 8, 8) in /home/mysite/public_html/includes/database.mysql.inc on line 167.

Can't DROP 'field_titolo_url_url'; check that column/key exists query: ALTER TABLE d1_node_software DROP field_titolo_url_url in /home/mysite/public_html/includes/database.mysql.inc on line 167.

Comments

Sounds like you might not have run update.php after upgrading the link module. Or if you did, did you get any errors during the update?

After upgrading there has not been any error. I now have reinstalled the module and runned the upgrade's script. It seems to work. If there will be still problems I will update the issue.

Someone you has had the same problem?

I have made some other tests and the procedure that causes the error SHOULD BE this:

1. new content type created
2. new link field created
3. new node (based on the new content type) created
4. node deleted
5. link field deleted
6.now, when I rename the content type (Name and Type), i get this error:

user warning: Can't find file: './mysqldb/node_software.frm' (errno: 2) query: RENAME TABLE node_software TO node_free_software in /home/mysite/public_html/includes/database.mysql.inc on line 167.

It is the cause of the following errors.

Title:Error on link's field managingI forgot..

..for don't get the error I have to rename the Type with the old name.
Is it a Link module or a CCK module problem?

Title:I forgot..i'm sorry for all these updates

I have just tried disabling the Link module but I still get the error.
So it should not be related to it but probably to the CCK module.

Status:Active» Closed (fixed)

Hey duser, no problem. It sounds like this problem isn't directly caused by link.module if it still occurs without the module enabled. Please reopen if you find link did cause the problem.