Hi,

I just did a fresh install of Drupal 7, with standard settings and downloaded the dev version of Zen for Drupal 7. I've downloaded the file, extracted it to the all/themes folder and navigated to admin/appearance/list. And this is where the problem starts.

The page wont load. Firefox tells me "The connection to the server was reinitialized while loading the page." In all other browsers the overlay pops up without any content (so i just get a black overlay).

Drupal installation:
- Drupal 7.0 (2011-Jan-05 )

Zen Theme:
- Zen 7.x-3.x-dev (2011-Mar-03)

Other modules installed:
- Administration menu 7.x-3.0-rc1 (2011-Jan-07)
- Locale updater 7.x-1.0-alpha3 (2011-Feb-02)

Comments

Maybe some more important information:

Wampserver 2.1
Apache 2.2.17
PHP 5.3.4
MySQL 5.1.53

same problem for me

Category:bug» support
Priority:Critical» Major
Status:Active» Postponed (maintainer needs more info)

And when you remove the sites/all/themes/zen folder, you can get to the Appearance page again?

Yes, correct

That doesn't make any sense. Before the Zen theme is enabled, none of its code is loaded into Drupal. The only part of Zen that is used on the Appearance page is the zen.info file.

Let's do some testing to see if there's something in zen.info that's causing parts of Drupal to explode on your system. (btw, it doesn't explode on my system.)

What happens if you delete the following lines from zen.info and re-install it in sites/all/themes? Can you see the Appearance page then?

description = 'Zen sub-themes are the ultimate starting themes for Drupal 7.
              Read the <a href="http://drupal.org/node/873778">online docs</a>
              or the included README-FIRST.txt on how to create a theme with Zen.'

Exactly the same thing happens to me. I have tried for a couple days and always get the same situation - won't load and times out. If I remove the zen folder from sites/all/themes, the appearance tab works fine. I even created a my_zen sub-theme page and that works fine - just gives the message that it's missing the base if I set it to be the default (naturally, since I can't get that to load).

Then I put the newest zen 6.x version in the folder and it loaded fine too - but of course got the message that it was unsupported for Drupal 7.0. Tried to "update" to the newer version from the Drupal "update" link and got this message: "An AJAX HTTP request terminated abnormally. Debugging information follows. Path: /?q=batch&render=overlay&id=9&op=do StatusText: ResponseText: ReadyState: 4".

This morning (March 31, 2011) I downloaded the latest copy of the Zen 7.x-3x-dev that was loaded to the site just last night. Same result.

Drupal installation:
- Drupal 7.0 (2011-Jan-05 )

Zen Theme:
- Zen 7.x-3.x-dev (2011-Mar-31)

Other modules installed:
- Administration menu 7.x-3.0-rc1 (2011-Jan-07)
- Views 7.x-3.0-beta3 (2011-Mar-28)

Have tried this on:
Firefox: 3.6.16
Chrome: 10.0.648.204
Internet Explorer: 9.0.8112.16421

Wow - I just tried the suggestion to remove the description and after days of trying, the Zen base template loaded fine !!!!!!!!!!!!!!!!!!!!!!!!!

THANK YOU :-)

wow, deleting the description line worked for me too

Deleting the description works for me too.

Title:Can't install Zen Installing Zen prevents Appearance page from loading on some systems
Category:support» bug
Priority:Major» Critical

So… yay! That was a good guess of mine.

But, crap. That means there's a core bug that is causing multi-line values in .info files to crash your version of PHP.

fcjversc already posted the information about her (his?) website configuration

Wampserver 2.1
Apache 2.2.17
PHP 5.3.4
MySQL 5.1.53

Can the rest of you who experience this also post details about your PHP, webserver and OS? Maybe we can find a commonality for all of you and we can figure out a fix for core.

Category:bug» support
Priority:Critical» Major

My setup is also:

Wampserver 2.1
Apache 2.2.17
PHP 5.3.4
MySQL 5.1.53

Category:support» bug
Priority:Major» Critical

In the meantime, I've changed the description line in the .info files to just be a single line instead of multi-line. http://drupalcode.org/project/zen.git/commit/804cb76

Instead of just deleting the description line in zen.info, can you instead use this line? I want to make sure that the change I just committed will work for everyone.

description = Zen sub-themes are the ultimate starting themes for Drupal 7. Read the <a href="http://drupal.org/node/873778">online docs</a> or the included README-FIRST.txt on how to create a theme with Zen.

@JohnAlbin i'm a 'His' ;)

Editting the .info with the single-line description works for me :)

Editting the .info with the single-line description works for me :)

Sweet. That means the fix I already committed works around the issue.

I'd still like to see more server setup information so we can create a core issue for the underlying bug.

I just updated to Zen 3.0 (D7) from 3.x-dev and my theme is still showing up but in the Apperance page I see this message: "This version is not compatible with Drupal 7.x and should be replaced."

Chris, that's not what this issue is about; this issue is about a fatal PHP error on some systems.

Please open a new issue and describe your problem a bit more fully. Thanks.

Chris, I think your issue is there because the XML file with release information is not updated yet (cached) on Drupal.org. This is what the update manager checks against. I've seen this issue for someone else. Not sure it's the same though.

I just tried to "rewind" the lates dev to "multilined description", and had no error. Something else fixed that caused the problem?

Or is it system related? Hosted site running Litespeed (version unknown), PHP 5.2.14, MySQL 5.1.41-3ubuntu12.10-log.

Related to PHP 5.3.x?

mine is
Wamp server : 2.1
Apache Version : 2.2.17
PHP Version : 5.3.5
MySQL Version : 5.5.8
and Drupal 7.

as per the posts, i tried changing the description to 1 line, but i still happen to experience the same problem..
i even tried removing the description tag then also not working..
i tried re installing not working..

can any1 pls help?

im new to drupal, so a a step by step instruction would do gr8..

@chefdro Are you using Zen 7.x-3.0 now? I don't think anyone else is experiencing this problem with that version. (At least, I hope not!)

sorry about that.. i used zen core 7.x-3.x-dev drupal 7..

but didnt realize that zen proper is released..
now it works..

Status:Postponed (maintainer needs more info)» Fixed

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

Title:Installing Zen prevents Appearance page from loading on some systemsI had a different case

In my case removing the description didn't help.

I found that the STARTERKIT.info.txt had a somewhat different file type than zen.info.

So i copied zen.info to my theme instead of STARTERKIT.info.txt, And put all the necessary data there (From STARTERKIT.info.text).

It worked. (I'm using mac)

Title:I had a different caseInstalling Zen prevents Appearance page from loading on some systems

@rantebi you should have tried changing the filename from STARTERKIT.info.txt to STARTERKIT.info (actually, to THEME_NAME.info, have you read the README file?)

@rantebi you should have tried changing the filename from STARTERKIT.info.txt to STARTERKIT.info (actually, to THEME_NAME.info, have you read the README file?)