I have VideoJS enabled for mp4, webm, ogv, ogg. Flowplayer for flv. When I try to play the video in Internet Explorer 8, I get the following error:

Message: 'config' is null or not an object
Line: 78
Char: 11
Code: 0
URI: http://domain.ltd/sites/all/modules/flowplayer/flowplayer.js?lj8tmt

Webpage error details
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; chromeframe/10.0.648.204; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET4.0C; .NET4.0E)

Comments

Version:7.x-1.0-unstable2» 7.x-1.0-alpha2

Title:When VideoJS is enabled for WebM format in admin/config/media/video/players there is no video in Internet Explorer When VideoJS is enabled for html5 formats there is no mp4 video in Internet Explorer
Priority:Major» Critical

Narrowed down the problem.

Used
Video module version 7.x-1.x-dev (2011-Apr-07)
VideoJS module version 7.x-1.x-dev (2011-Apr-07),
Flowplayer module version 7.x-1.x-dev (2011-Mar-29)

the error messages have gone, but the video in Internet Explorer doesn't play if I choose the VideoJS instead of Default HTML5 for webm format (or ogv format). But when I choose the Default HTML5 for webm format (or ogv format), the video plays fine in Internet Explorer.

Title:When VideoJS is enabled for html5 formats there is no mp4 video in Internet Explorer When VideoJS is enabled for web format there is no video in Internet Explorer
Version:7.x-1.0-alpha2» 7.x-1.x-dev
Priority:Critical» Major

Changed the title.

Status:Active» Postponed (maintainer needs more info)

what are the steps to reproduce?

Title:When VideoJS is enabled for html5 formats there is no mp4 video in Internet Explorer When VideoJS is enabled for web format there is no video in Internet Explorer
Priority:Critical» Major
Status:Active» Postponed (maintainer needs more info)

In admin/config/media/video/players
choose the VideoJS for mp4, ogg, ogv and webm format, Flowplayer for flv.

Use Internet Explorer 7 or Internet Explorer 8 to visit the video node. The video is not played.

(If you choose Default HTML5 back from VideoJS for the webm format (or ogv format) and use IE7 or IE8 to visit the video node, the video gets played fine.)

Status:Postponed (maintainer needs more info)» Active

Title:When VideoJS is enabled for web format there is no video in Internet Explorer When VideoJS is enabled for WebM format in admin/config/media/video/players there is no video in Internet Explorer

Title:When VideoJS is enabled for web format there is no video in Internet Explorer When VideoJS is enabled for WebM format in admin/config/media/video/players there is no video in Internet Explorer
Status:Postponed (maintainer needs more info)» Active

Just used the 7.x-1.x-dev dated April 22, 2011 - 16:20. Same thing. Flowplayer doesn't play the videos when VideoJS is enabled for ogv format.

Used
Video module version 7.x-1.x-dev (2011-May-02)
VideoJS module version 7.x-1.x-dev (2011-Apr-07),
Flowplayer module version 7.x-1.x-dev (2011-Mar-29)

Flowplayer doesn't play videos in IE when VideoJS player is enabled for mp4, webm, ogv, ogg. If I choose html5 for either webm or ogv, the video gets played (and html5 is used for all of them).

@anglo, sorry I do not have IE to reproduce this. Could some one tell me the error messages and more debug info.

@heshan.lk,
You can download the disk image XPSP3-IE8.EXE (520MB WindowsXP and IE8 installed) from
http://www.microsoft.com/downloads/en/details.aspx?FamilyID=21eabb90-958...

And download VirtualBox from
http://www.virtualbox.org/wiki/Downloads

Extract the .vhd file from XPSP3-IE8.EXE and use it in VirtualBox.

Thanks, will do

Status:Active» Closed (won't fix)

Status:Closed (won't fix)» Needs review

I had the same error with Flowplayer API 7.x-1.0-alpha1. To correct this, navigate to admin/config/media/flowplayer . Click on "Save configuration". Once these settings are configured, then the "config is null" error will disappear. Perhaps a bug should be filed with the Flowplayer API, as there should be default settings for the Flowplayer API, or a warning message to configure it upon installation.

Status:Needs review» Closed (won't fix)

This is a Flowplayer issue and seems to be equal to #1213144: Flowplayer API breaks modulefilter js.