Hi infojunkie!

I downloaded the latest dev version and now i have this error message:

Missing argument 1 for views_plugin_exposed_form::pre_render(), called in C:\wamp\www\mysite\sites\all\modules\views_hacks\views_composite_exposed_form\views_composite_exposed_form_plugin.inc on line 96 and defined in C:\wamp\www\mysite\sites\all\modules\views\plugins\views_plugin_exposed_form.inc on line 158.

I think the problem is with the last commit.

Comments

Title:Error message since the latest commit views_plugin_exposed_form::pre_render() missing argument
Status:Active» Fixed

Fixed in the latest dev. Please try it (12 hours from now) and let me know how it works.

Hi infojunkie!

It seems to work well.

Thank you for your work :)

Component:General» Views Composite Exposed Form

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

Status:Closed (fixed)» Active

thanks for this add-on. I have applied the latest dev release but unfortunately still having the issue in the original post.
I'm using Selective Exposed Filters with Better Exposed Filters. both filter plugins actually work, it's just the error message keeps being displayed. how do i remove it?

@fatcheeks: Make sure you don't have two versions of the same module in different folders of your installation - that's one of the main reasons for these mysterious bugs.

hi infojunkie. thanks for your response. I've checked my installation folder and only the dev version is installed.
I had to remove the $values argument from the pre_render() function definition to fix it. is this the 'right' solution? please let me know if there is a better way.

this is the error message I was having.
warning: Missing argument 1 for views_composite_exposed_form_plugin::pre_render(), called in C:\Users\Administrator\Sites\acquia-drupal\modules\acquia\views\includes\view.inc on line 826 and defined in C:\Users\Administrator\Sites\acquia-drupal\sites\all\modules\views_hacks\views_composite_exposed_form\views_composite_exposed_form_plugin.inc on line 94.

Status:Active» Fixed

@fatcheeks: Please use the latest version of Views 6.x-3.x. The signature for the method views_plugin_exposed_form::pre_render has changed to match what Views Composite Exposed Form expects.

yes, that fixed it.
thanks again, really appreciate your help.

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.