This is the first time I've used Git.
For project http://drupal.org/project/user_settings_access

I followed the instructions (http://drupal.org/project/user_settings_access/git-instructions) to download the latest D7 version, made changes and a commit locally and a push back to drupal.org.
(http://drupalcode.org/project/user_settings_access.git/commit/9d1e030)

As you can see, the commit is logged but the date for 7.x-1.x-dev hasn't changed and the download doesn't contain the new files.

What am I doing wrong?

Files: 
CommentFileSizeAuthor
#9 file_dates.png288.98 KBeliza411

Comments

Category:support» bug

I've changed this to a bug report.
The date has now changed (it took a while) but the downloaded files don't contain the change I made.

In your local environment, when you run git status while you have your D7 version checked out, what's it telling you?

Here is a complete list of the commands I did and the responses:

Welcome to Git (version 1.7.4-preview20110204)

Run 'git help git' to display the help index.
Run 'git help ' to display help for specific commands.

User1@PC1 ~
$ cd git

User1@PC1 ~/git
$ pwd
/c/Documents and Settings/User1/git

User1@PC1 ~/git
$ git status
fatal: Not a git repository (or any of the parent directories): .git

User1@PC1 ~/git
$ git clone --branch 7.x-1.x tchurch@git.drupal.org:project/user_settings_acces
s.git
Cloning into user_settings_access...
tchurch@git.drupal.org's password:
remote: Counting objects: 17, done.
remote: Compressing objects: 100% (13/13), done.
remote: Total 17 (delta 7), reused 12 (delta 4)
Receiving objects: 100% (17/17), 8.12 KiB, done.
Resolving deltas: 100% (7/7), done.

User1@PC1 ~/git
$ git config --global user.email tchurch@424688.no-reply.drupal.org

User1@PC1 ~/git
$ git status
fatal: Not a git repository (or any of the parent directories): .git

User1@PC1 ~/git
$ cd user_settings_access/

User1@PC1 ~/git/user_settings_access (7.x-1.x)
$ git status
# On branch 7.x-1.x
nothing to commit (working directory clean)

User1@PC1 ~/git/user_settings_access (7.x-1.x)
$ git status
# On branch 7.x-1.x
# Changes not staged for commit:
# (use "git add ..." to update what will be committed)
# (use "git checkout -- ..." to discard changes in working directory)
#
# modified: user_settings_access.info
# modified: user_settings_access.module
#
no changes added to commit (use "git add" and/or "git commit -a")

User1@PC1 ~/git/user_settings_access (7.x-1.x)
$ git branch -a
* 7.x-1.x
remotes/origin/6.x-1.x
remotes/origin/7.x-1.x
remotes/origin/HEAD -> origin/master
remotes/origin/master

User1@PC1 ~/git/user_settings_access (7.x-1.x)
$ git status
# On branch 7.x-1.x
# Changes not staged for commit:
# (use "git add ..." to update what will be committed)
# (use "git checkout -- ..." to discard changes in working directory)
#
# modified: user_settings_access.info
# modified: user_settings_access.module
#
no changes added to commit (use "git add" and/or "git commit -a")

User1@PC1 ~/git/user_settings_access (7.x-1.x)
$ git add -A

User1@PC1 ~/git/user_settings_access (7.x-1.x)
$ git status
# On branch 7.x-1.x
# Changes to be committed:
# (use "git reset HEAD ..." to unstage)
#
# modified: user_settings_access.info
# modified: user_settings_access.module
#

User1@PC1 ~/git/user_settings_access (7.x-1.x)
$ git commit -m "Issue #1146988 by tchurch: Admin Role Permission."
[7.x-1.x 9d1e030] Issue #1146988 by tchurch: Admin Role Permission.
2 files changed, 39 insertions(+), 10 deletions(-)

User1@PC1 ~/git/user_settings_access (7.x-1.x)
$ git status
# On branch 7.x-1.x
# Your branch is ahead of 'origin/7.x-1.x' by 1 commit.
#
nothing to commit (working directory clean)

User1@PC1 ~/git/user_settings_access (7.x-1.x)
$ git push origin 7.x-1.x
tchurch@git.drupal.org's password:
Counting objects: 7, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (4/4), done.
Writing objects: 100% (4/4), 994 bytes, done.
Total 4 (delta 3), reused 0 (delta 0)
To tchurch@git.drupal.org:project/user_settings_access.git
aaeb3ad..9d1e030 7.x-1.x -> 7.x-1.x

User1@PC1 ~/git/user_settings_access (7.x-1.x)
$ git status
# On branch 7.x-1.x
nothing to commit (working directory clean)

User1@PC1 ~/git/user_settings_access (7.x-1.x)
$ git status
# On branch 7.x-1.x
nothing to commit (working directory clean)

User1@PC1 ~/git/user_settings_access (7.x-1.x)
$

Assigned:Unassigned» sdboyer

Thanks. From your description I wasn't sure if you were missing new files, too.

It looks like the changes you expected to see were successfully included in the commit you linked to above and successfully pushed to Drupal.org, but http://ftp.drupal.org/files/projects/user_settings_access-7.x-1.x-dev.ta..., now that the tarball has been recreated, still doesn't contain the changes.

This appears to be related to #1153392: Project download links are pointing to missing files
When I look at http://drupal.org/files/projects/user_settings_access-7.x-1.x-dev.tar.gz (note the absence of ftp in the url) the updated files appear.

Status:Active» Fixed

Verified that the changes as I understand them are visible at both URLs since #1153392: Project download links are pointing to missing files was fixed. If I've missed something, please re-open.

No. The ftp link (as on the project page) still gives me the wrong file.

How long should it take?

Should I also put a comment on the other issue?

I must be looking for the wrong thing.

When the tarball was wrong, I saw that the 7.x info file contained the line:
core = 6.x instead of
core = 7.x

Now, I see the .info file contains the right core version at both URLs.

What, specifically, is still out of date?

I download the tar.gz file for 7.x using the ftp link on the project page and unzip it. It still contains the old .info and .module files (25-feb dates and content is old).

The link without ftp does give me the correct file.

StatusFileSize
new288.98 KB

Sorry if I'm missing something here. Perhaps you're having some local caching issues?

I follow the link on the Project page, http://ftp.drupal.org/files/projects/user_settings_access-7.x-1.x-dev.ta...

I see what seem to be the proper file dates and contents. See the attached screenshot.

Not sure what happened there then. Could have been a cache issue. I cleared my cache, refreshed the page and downloaded the correct file.
Thanks.

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

Status:Closed (fixed)» Active

It happens the same to me:

1) First time using Git.
2) Appearing "Fatal: Not a git repository (or any of the parent directories): .git

Working on it, comment soon if solution is found!

Status:Active» Closed (fixed)

I think you'll get better response if you open your support request as a new issue rather than tacking it on to this one directly. Your problem doesn't sound related, and the data from the previous support request doesn't apply.