This line (474 of wysiwyg_imageupload.module):

    if (!preg_match('@1\.[3,4]\.\d+@', $jqv)) {

Is too restrictive and doesn't let you use newer version of jQuery.
For example if you use jQuery 1.5.2 from #1067290: Fix jQuery 1.7 for Drupal 6

Can it be modified to just require 1.3.2 or higher?


Status:Active» Postponed (maintainer needs more info)

it will not work anyway. So this is by design. jquery ui 1.7 needs jquery 1.3 to work. and the current dialog implementation ( or rather D6 overall ) does not support jquery 1.8.x which support jq > 1.3.

So its rather not the question about jquery but ( and the regexp ) but rather jquery ui and its compatibility.

You can go foward and test jq 1.5x with 1.7 jq ui under D6, but i expect it to explode right away :)

Status:Postponed (maintainer needs more info)» Closed (works as designed)

Sir you are correct. It doesn't work.
Thanks for the headsup.

I think I'll try to get around my other issues that require jQuery > 1.3.2 in a better way and use 1.4.2 instead of that 1.5.2 jquery update port.

Marking as works as designed.

Title:Doesn't work for newer jQuery versionsSupport newer jQuery and jQuery UI versions
Status:Closed (works as designed)» Active

So is it feasible to ask for jQuery UI 1.8.x (and therefore jQuery > 1.3.2) support or will it require too much effort and won't be happening for D6?

Status:Active» Postponed

Well test it, try it, patch it and iam happy to include it :) But until then, i just postpone it, reopen if you start working on it.