This is the error when i try to search something with finder

ResponseText: PDOException: SQLSTATE[HY093]: Invalid parameter number: parameter was not defined: SELECT node.title AS finder_element_1_node_title
FROM
{node} node
WHERE (( (node.type IN  (:db_condition_placeholder_0_#conjunction, :db_condition_placeholder_0_0, , :db_condition_placeholder_2)) ))
GROUP BY finder_element_1_node_title; Array
(
[:db_condition_placeholder_2] => 1
[:db_condition_placeholder_0_#conjunction] => OR
[:db_condition_placeholder_0_0] => Array
(
[field] => news
[value] =>
[operator] => IS NULL
)
)
in finder_find_query() (linea 1038 di /****/sites/all/modules/finder/finder.module).

Comments

Got this error too. Tried Node Finder using Autocomplete. Subscribing. Thanks.

Status:Active» Fixed

Cheers guys, a few things in autocomplete weren't upgraded properly.

Status:Fixed» Active

this is still an issue for me

Title:Ajax error 500 - Invalid parameter number: parameter was not definedInvalid parameter number: parameter was not defined

Seems to affect other things than autocomplete as well.
bugger me, it's a tough one to figure out

I think finder_conditions() need to be rewritten. I tried my best to use the D7 database API to create 'groups' of conditions, but I just don't think it works.

Priority:Normal» Critical

Status:Active» Needs review

I've committed a fix it should appear in the next dev snapshot.

Status:Needs review» Fixed

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

I'm getting the same error using the sqlsrv module... i was wondering, could you post your fix or explain what you did to fix the problem?

UPDATE: nm, found patch at http://drupal.org/node/1153174#comment-5097508 from http://drupal.org/node/1286792#comment-5097526.