Strict warning: Creating default object from empty value in user_relationship_blocks_block_view() (line 214 of C:\xampp\htdocs\drupal\sites\all\modules\user_relationships\user_relationship_blocks\user_relationship_blocks.module).
Strict warning: Creating default object from empty value in user_relationship_blocks_block_view() (line 214 of C:\xampp\htdocs\drupal\sites\all\modules\user_relationships\user_relationship_blocks\user_relationship_blocks.module).
Notice: Trying to get property of non-object in theme_user_relationship_block_subject() (line 99 of C:\xampp\htdocs\drupal\sites\all\modules\user_relationships\user_relationship_blocks\user_relationship_blocks.module).

The module works. I was able to send a friend request from my admin account to a test user I set up and the test user accepted the friend request. Under my relationships and friends it shows the test user I created. I'm new to using drupal and I can't figure out how to fix this error.

Comments

Category:support» bug
Status:Active» Postponed (maintainer needs more info)

Can you please verify if the patch in #1211066: Error when editing "Block User Relationships: relationship name" fixes this?

Component:Miscellaneous» Blocks

Status:Postponed (maintainer needs more info)» Fixed

The mentioned issue has been fixed, I'm closing this unless someone can confirm that this stil happens with alpha3 or the latest -dev version.

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

Status:Closed (fixed)» Active

Notice: Trying to get property of non-object en theme_user_relationship_block_subject()

in 7.x-1.0-alpha4