This release adds support for (and requires) version 7.x-1.0-beta4 of the Media module. Note that Media Gallery is not yet compatible with development snapshots of Media module. There will be another beta release of both Media and Media Gallery when the latest work on each is compatible with each other.

Then update the .info file according to the drupal best practises:

dependencies[] = media (>=1.0-beta4)

Comments

Priority:Critical» Normal

That seems reasonable (at least it would make sure that people aren't running it with Media 7.x-1.0-beta3 or something).

But I'm not sure it would help with the main issue... if they try to run it with a Media development snapshot, would it still let it through? Do you know offhand? I'm guessing it probably would.

ok then if you want to block it for beta4 (no -dev)

dependencies[] = media (1.0-beta4)

It will then ensure the code is not compatible with a dev snapshot.

If you want more info: http://drupal.org/node/542202#dependencies

Status:Active» Needs review
StatusFileSize
new2.68 KB

I did some testing, and it looks like if you use version dependencies at all (regardless of whether you specify the >= or not), dev snapshots are always blocked. That's a little odd, but for our case I think it's what we want anyway.

The attached patch updates the info files and README.txt for the releases that the next version of Media Gallery is expected to be compatible with. I think we should commit this patch right before Media Gallery 7.x-1.0-beta6 is released, and then roll it back after the release (so people can continue to use the dev snapshots with each other).

Hopefully this will help cut down on some of the bug reports and support requests :)

StatusFileSize
new2.77 KB

New patch, with some additions from @effulgentsia originally written in another issue (forgot to mention the new Ctools dependency in the README.txt file).

Status:Needs review» Fixed

Committed this right before the 7.x-1.0-beta6 release, then rolled back the info file changes on the 7.x-1.x branch (so that dev versions of the various modules can still be tested against each other):
http://drupalcode.org/project/media_gallery.git/commit/d6d29ff
http://drupalcode.org/project/media_gallery.git/commit/5927ba3

Guess we'll see how it goes, and perhaps add something like it back to the info files right before the next (7.x-1.0-beta7?) release.

I'm having problems with the version dependency on media_gallery.

$ drush pm-enable -y media_gallery
Module media_gallery cannot be enabled because it depends on media (1.0-beta5) but 7.x-1.0-beta5 is available

$ cat ../../profiles/site_profile/modules/contrib/media/media.info | grep version
version = "7.x-1.0-beta5"

Any ideas?

Same problem here as #6.

I had the same problem as in #6, enabling the module through the UI worked fine. Might be a Drush bug...

Status:Fixed» Needs work

Same problem as #6. also works for me if done through the UI rather than drush.

Status:Needs work» Fixed

confirming #6.
as pointed out in #8 i would say this is a drush bug so marking as fixed and opened #1322532: drush pm-enable dependency resolution bug

Note: I had the same problem when trying to enable a Feature module that contained a dependency on media. The only way I can get the Feature enabled is through the Modules page (it doesn't work at /admin/structure/features, or through drush)

posted a fix at #1322532: drush pm-enable dependency resolution bug, maybe someone wanna review.

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

Is this module compatible with media rc2 ?

It would be nice to have this dependency fixed as is seem to easy to fix.

Thanks

@pitxels, have you looked at the README.txt file in the latest Media Gallery release? It says very clearly which versions of which modules this is compatible with. And it specifically mentions Media 7.x-1.0-rc2...