When I enable colorbox for user/login links from its administration area all correspondent links open up in colorbox.

After succesfully login in though the module redirects the user to a page where the language prefix appears twice in the URL.

Lets say you are at: http://www.example.com/el/node/5
You click Login, colorbox opens up and you login
Then colorbox sends you at: http://www.example.com/el/el/node/5

Notice the second /el above! This doesn't happen with core drupal, probably because it redirects user to: users/[user-raw]

Anybody else having the same issue?
I suppose this happens inside the .js and not inside the php files, although I might be wrong...

Files: 
CommentFileSizeAuthor
#7 colorbox-1181448-7.patch1.09 KBiMiksu

Comments

Version:6.x-1.0-beta9» 6.x-1.1
Component:Miscellaneous» User interface
Priority:Normal» Major

I am having the same problem with version 6.x-1.1 of Colorbox, when someone tries to login from a page like www.domain.com/en/node/5 they are not brought back to the same page, but rather sent to www.domain/en/en/node/5. I believe that the Colorbox module is not taking into account content translation and its considering /en as part of the link, when its part of the language.

The content translation module is receiving the link as follow:

http://www.domain.com/en/user/login/colorbox?destination=en/node/5

Maybe it should be as follow:

http://www.domain.com/en/user/login/colorbox?destination=/en/node/5

drupal 7.x.1.2 has the same issue

as a work around until one of us can figure out what is happening you can use the user login hook like this:

<?php
function example_user_login(&$edit, &$user) {
  global
$language;
  if(
$_GET['destination'] == $language->language || stripos($_GET['destination'],"{$language->language}/") === 0) {
   
$_GET['destination'] = substr($_GET['destination'], 3);
  }
}
?>

I gave up on the idea of colorbox+prefixes because I solved the problem with subdomains for language negotiation.
The reason I did that was not colorbox but the backends of greek-banks... a long story!

Sadly I do not have any solution/info on the issue.

Version:6.x-1.1» 7.x-1.3

I have the same problem on 7.x-1.3.
Is there a solution?

Status:Active» Closed (won't fix)

The attempt to support opening various forms in a Colorbox was in hindsight never a good idea. Form error handling and form redirects are complicated, a lot of code would be needed to do it correctly. The 7.x-2.x branch removes the form support from the Colorbox module.

StatusFileSize
new1.09 KB

The problem was caused by JS behavior callback at colorbox_login.js which did not take into account the possible path prefix.

I've attached a patch against 7.x-1.3 version which should take care of that nicely.

Hopefully fixes this issue for those who still lives with mentioned version :)