Meanwhile I explicitly put the description above the banner images as I did with the navigation, the description is only visible for the short moment, when two pictures fade. If I chose the settings for description "behind!" it is never visible at all. but I want it really to be above the banner pictures. how can I fix this?
best
fahl5

Comments

I'm having the same problem. The titles and descriptions were showing originally, and then I experimented with different options, and now can't get the titles back. Maybe it is in the interaction of settings?

My titles *very* briefly flash as the pictures change. The banner navigation buttons remain over the banner. If I click the nav button, the titles flash for a little longer, then are replaced by the banner picture.

I tried changing the effect from fadescroll to wipe but that didn't fix the problem.

My settings are:
Do you want to use Marinelli banners or a classic drupal region? Marinelli banners
Choose the effect of your banner : fadescroll
Choose the rotation speed (milliseconds, default is 1000) : 1000
Choose the banner delay (milliseconds, default is 4000) : 4000
Pause on hover? YES
Do you want to show title and description over the banner? yes
Do you want to show the banner navigation over the banner? yes

I have 9 images, all of which are published. The problem showed up after I was loading and deleting a bunch of images. Before the problem some of my images didn't have titles, but deleting some of the titles doesn't fix it.

I have exactly the same bug. The text is disappearing very fast. It worked well with 7.x.3.0.-beta 9. Does anyone have a solution?

I tested several options and I found out that the bug appears for me only if I have more than 7 banners. It works fine until i upload banner number 8 which breaks the visibility of the title and the description.

Same problem here.

Same problem here. I've just unpublished some of them (to get < 8 active banners) and now it works again.

Also I still have the problem today (12/4/2011). My setting are like from @firstcong. Who can help? What is the opinion of Matteo Leoni? Will there be help? -
Thanks.

This problem also shows for me. I have done as jgrocha did and deleted images to leave a max of 7 banner images and all is well. However I need to display 13 banner images. Will there be a fix for this bug/problem?
Thanks

Status:Active» Fixed

You can find the solution by Frits1980 here http://drupal.org/node/1035948#comment-4137500

Basically it involves changing the z-index in slideshow.css, so if you change the z-index value to 109, which is just below the z-index for navigation buttons at 110, you will have working titles for the first 107 images? (I had the same problem and i guess the explanation must be, that in the CSS on my Marinelli version the z-index for text was 9 which probably means, that with image z-index value set to 2 the the images will display above the text with more than 7 images because the 7 images then occupy 2-8, and thus image 8 will get the z-index 9 and thus hiding the image text?)

Anyway it may not be the right explanation, but I put the solution below in my subtheme, and everything works as a charm...

P.S. Don´t forget to put the changes in your subtheme, and not the main CSS...(For info on subtheming Marinelli see this page: http://drupal.org/node/1000284 , and for general subtheming info see this page: http://drupal.org/node/225125 )

Solution:

in the CSS file slideshow.css replace this:
"
#header-image-text{ /* image text container */
position: absolute;
bottom: 0px;
left: 0px;
z-index: 9;
width: 100%;
}
"
With this:
"
#header-image-text{ /* image text container */
position: absolute;
bottom: 0px;
left: 0px;
z-index: 109;
width: 100%;
}
"

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

Status:Closed (fixed)» Closed (duplicate)

Not really fixed- more correctly a duplicate of #1035948: Marinelli Banner is not Showing up in drupal site

Version:7.x-3.0-beta11» 6.x-2.9

I cannot see slideshow.css. Is this fix only good for version 7 or 6 as well?