Thanks you.. This is Very beautiful theme in D7..

i am getting this message below the grid..how to get rid of this issue..
and if possible give some more details on Grid installation.

How to add grid as.
1.Block
2.Page
3.Something else.

Thanks in advance.

-Saadmanna

Files: 
CommentFileSizeAuthor
error.png535.32 KBsaadmanna

Comments

1) "How to get rid of the message"
Usally you only can see the message for adding new content, if you are logged in with an account that may add new content. This is not a bug..... its a feature :D

To get "rid" of this message you have to:
1) Check if you are logged in (i.e. as admin)
2) log out
3) reload the homepage
4) find out that the message is gone :D

Well, if it is still there please make a follow up on my post.

2) Adding a grid
RTFM :) http://drupal.org/node/1181286

You can add the code below to any content page or block you like and the "grid" system should appear.

<div class="grid-parent">
    <div class="grid-child grid-25 grid-space-right">
        <h2>Headline 1</h2>
        <p><img src="path/to/image"</p>
        content
        <h3><a href="add/link/here">Read More!</a></h3>
    </div>
    <div class="grid-child grid-25 grid-space-right">
        <h2>Headline 2</h2>
        <p><img src="path/to/image" border="5"</p>
        content
        <h3><a href=add/link/here>Read More!</a></h3>
    </div>
    <div class="grid-child grid-25 grid-space-right">
        <h2>Headline 3</h2>
        <p><img src="path/to/image" border="5"</p>
        <h3><a href=add/link/here>Read More!</a></h3>
    </div>
    <div class="grid-child grid-25">
        <h2>Headline 4</h2>
        <p><img src="path/to/image" border="5"</p>
        content
        <h3><a href=add/link/here>Read More!</a></h3>
    </div>
</div>

I hope that helped. Please let us know if you problem is fixed.

Assigned:Unassigned» yshido

Priority:Normal» Minor

I have tried those option previously.. i get that message for anonymous log-in, i also checked the permission settings there is no option enabled for the anonymous user to create a page.

This was the main reason i wanted to know whether Grid is page or block in your demo website.

Thanks for your Quick reply...

Unfortunetaly I cant answer the question, if the grid is a block or page on the demo, but I was able to reproduce your issue.

If there is no content on the main page and the grid is a block the following message is shown for any user (incl. anonymus):
"No front page content has been created yet"

The option to set the grid within a normal page works, but it is not the ultima ratio. The reasons are, that the title of a normal page will allways be shown and you will only see a shortened version.

I hope Arshad will review this issue soon.

Assigned:yshido» Unassigned

The grid shown in the demo is actually not a block but a page. Here's how to make something similar.

  1. Create a new page by visiting Content -> Add content -> Basic Page
  2. Add the title of your page.
  3. In the body field, create your grid using the sample code below:

    <div class="grid-parent">
        <div class="grid-child grid-25 grid-space-right">
            <h2>Headline 1</h2>
            <p><img src="path/to/image"</p>
            content
            <h3><a href="add/link/here">Read More!</a></h3>
        </div>
        <div class="grid-child grid-25 grid-space-right">
            <h2>Headline 2</h2>
            <p><img src="path/to/image" border="5"</p>
            content
            <h3><a href=add/link/here>Read More!</a></h3>
        </div>
        <div class="grid-child grid-25 grid-space-right">
            <h2>Headline 3</h2>
            <p><img src="path/to/image" border="5"</p>
            <h3><a href=add/link/here>Read More!</a></h3>
        </div>
        <div class="grid-child grid-25">
            <h2>Headline 4</h2>
            <p><img src="path/to/image" border="5"</p>
            content
            <h3><a href=add/link/here>Read More!</a></h3>
        </div>
    </div>
  4. Make sure you choose Full HTML as the text format.
  5. Save your page.
  6. Copy the path (url) of the page. Example. if your page url reads http://example.com/node/120, copy node/120.
  7. Next, go to Configuration -> Site information. Under Default front page, paste the url and hit save.
  8. That's it. If you visit your front page now, you should see the grid and the message gone.

Hope this helps.

Works as discribed. Thanks!

I also tried this... but it shows the "Page tittle".. and "Read more..."

hence i used "." as the page tittle. but i am not able to get rid of READ MORE.

Weird,
try to use something else as page title. I have used "home" without the quotes and dont use URL-Aliases.

Further, please check your settings under Configuration -> Site information. Have you set the correct value for the default-homepage? Within the field you are only allowed to set "node/number_of_the_note" without the quotes.

Thanks its Working...

Status:Active» Fixed

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

OK sorry to open this again.. But...

I did everything you said.. shows up great, but now my image for the banner does not show up while logged in. But if not logged in everything shows up great.. Any idea why??

Never mind, for some reason everything is working correctly.

Am sorry for opening this issue up again but is there any way of getting rid of "No frontpage content has been created ". When you login as both administrator , authentic or anonymous user it still shows. I have gone through the theme files but am not able to get rid of it. Is there any way ???

Here was my simple fix, since I don't really care to ever see that message:

Edit sites/all/themes/andromeda/css/structure.css (Or any of the other main CSS files for the theme)
Add this to the bottom:

#first-time {
  display: none;
}

NOTE: This will make it invisible to users, however, its still in your HTML so search engines may see it. That shouldn't be a big issue for most people though.

It worked for me , THANKS

You should create a page and set it as the front page. See #7

I have a website whose home is only showing blocks, no nodes at all, after much searching and hair pulling I found a clean and quick solution, thanks to Mohammed Uzair Ahme:
http://drupal.stackexchange.com/questions/12908/how-to-remove-add-new-co...

Just add this code to the page.tpl.php or page--front.tpl.php on Drupal 7.

find

<?php print render($page['content']); ?>

and replace with below code.

<?php  if(drupal_is_front_page())
                {
                    unset(
$page['content']['system_main']['default_message']);
            }
        print
render($page['content']);
   
?>

And i believe you surely get all blocks or contents you posted on page.

and to remove page title on page like

Welcome to "website name"

find this code on page.tpl.php or page--front.tpl.php

<?php if ($title): ?><h1 class="title" id="page-title"><?php  print $title; ?></h1>
<?php endif; ?>

and you can remove this code or else just make a comment over.

Enjoy!!

This worked for me too !

Thanks mate!