I have created custom breadcrumb with the next cridentials:

Content type: Article
Titles:
[node:taxonomy-vocabulary-43:term:parent:name]
[node:taxonomy-vocabulary-43:term:name]
[node:title]
URLs:
[node:taxonomy-vocabulary-43:term:parent:url]
[node:taxonomy-vocabulary-43:term:url]

On the article node page it gives me correct breadcrumb:
Root → Parent taxonomy term → Taxonomy term → Node name

And the next warnings:
User warning: Attempting to perform token replacement for token type taxonomy-term-reference-field-value without required data in token_tokens() (line 757 of /home/sites/all/modules/token/token.tokens.inc).
User warning: Attempting to perform token replacement for token type taxonomy-term-reference-field-value without required data in token_tokens() (line 757 of /home/sites/all/modules/token/token.tokens.inc).
User warning: Attempting to perform token replacement for token type taxonomy-term-reference-field-value without required data in token_tokens() (line 757 of /home/sites/all/modules/token/token.tokens.inc).
User warning: Attempting to perform token replacement for token type taxonomy-term-reference-field-value without required data in token_tokens() (line 757 of /home/sites/all/modules/token/token.tokens.inc).

Comments

Status:Active» Postponed (maintainer needs more info)

Did this only happen with an anonymous user? If so this may already be fixed. I can't reproduce the problem with the latest code.

No, it happens with any user. How I can provide any additional information about the bug? Maybe some var_dump() results or anything else?

I also ran into this issue with Panels, my profile page and I added a node author token to the profile, which after changing it to title token it fixed.

For my case the node "profile" isnt a node, so i just used the title which is the user's name anyway.

This is happening with node tokens, as I have tested it on 2 diffrent "node" types: profile and gallery_image(my own type)

In case it might help:
I received the following error:
User warning: Attempting to perform token replacement for token type user without required data in token_tokens() (line 791 of ...modules\token\token.tokens.inc).
After changing the field-token "[user:field-paypal-email]" in "[current-user:field-paypal-email]" the error was gone.
So maybe it helps to check if the used token is correct.

Category:bug» feature

So maybe it helps to check if the used token is correct.

Yes, it seems that this problem is specific to the token used and the objects available. Custom breadcrumbs doesn't check to see if the token is valid - I am not sure if there is a way of doing that or not, but it seems that it might be necessary to avoid these warnings.

To avoid those warnings it might help to go to Home » Administration » Configuration » Development
=> Logging and errors
and set it to
none.