Download Size md5 hash
hierarchical_select-7.x-3.0-alpha3.tar.gz 86.74 KB e5b3f9a369f0f6c910cf1b20e540889a
hierarchical_select-7.x-3.0-alpha3.zip 103.54 KB cdb0dff34cd212d8a4290b949d024068
Last updated: August 21, 2011 - 15:11

Release notes

Highlights of this release:
- only one known remaining bug: #1242812: Previewing nodes deletes term reference values
- fixed major bug: multiple HS widgets on the same page could collide with each other
- save_lineage support
- upgrade path!
- fixed #required support
- fixed i18n support for HS Taxonomy
- fixed import & export

Make sure that you know if the part of Hierarchical Select's functionality that you want to use has been ported. Otherwise, you may be in for a frustrating upgrade experience.
See the included TODO.txt file for details. In a nutshell:
- Taxonomy support is almost complete, only "create new item", "entity count" and token support are missing
- Forum support has **not** yet been ported (but relies on Taxonomy, so this is trivial)
- Taxonomy Views support has **not** yet been ported
- Menu support has **not** yet been ported

This new version contains major patches sponsored by Bancard Data Service and PingV Creative!

Changes since 7.x-3.0-alpha2 (25+ commits):

  • Update README to reflect PingV's latest sponsorship effort.
  • Fixed #1127022: admin/config/content/hierarchical_select/configs generates incorrect links (should use get_entity_info())
  • Fixed #1255580: Provide proper upgrade path for Hierarchical Select, Taxonomy support and document this
  • Fixed a minor bug in commit e2b1c3c5, for #1068366.
  • Update TODO.txt to reflect the status of the current code base for Drupal 7.
  • Fixed #1176952: Config options in features UI have HTML escaped
  • Fixed #1197338 by ian.patterson: PHP Strict Warning in _hierarchical_select_hierarchy_enforce_deepest() on PHP 5.3
  • Fixed #1197338: PHP Strict Warning in _hierarchical_select_hierarchy_enforce_deepest() on PHP 5.3
  • Patch 3 for #1068354: HS Taxonomy widgets are always optional, #required is ignored: leverage Field API
  • Patch 2 for #1068354: HS Taxonomy widgets are always optional, #required is ignored: leverage Field API
  • Patch 1 for #1068354 by Peter Bex: HS Taxonomy widgets are always optional, #required is ignored: leverage Field API
  • Minor follow-up patch for #1068070: I forgot to update the code in one spot.
  • Follow-up patches for #1216214 by fietserwin & pfrenssen: D7 i18n Taxonomy compatibility
  • Fixed #1254104: HS Taxonomy widgets are always optional, #required is ignored
  • Follow-up patch for #1068366: Port "save lineage" functionality to D7 + support for multiple parents taxonomies (multiple parents support had been forgotten in the previous patch)
  • Fixed #1068070: When multiple HS widgets exist on the same page, and #process order != displayed order: Drupal's JS setting handling breaks HS
  • Implemented #1068366: Port "save lineage" support to D7. Sponsored by Bancard Data Service.
  • List official issue for tracking HS Taxonomy entity_count support in D7.
  • Fixed #1206766: README text not yet updated for D7 port
  • List official issue for tracking Views support in D7
  • Fixed #1082492 by Owen Barton: Form select can end up disabled in Firefox
  • Fixed #1216214 by fietserwin: D7 i18n Taxonomy compatibility
  • Follow-up fix for #1115498 by fietserwin.
  • Fixed #1198362 by fearlsgroove: Use widget label and description for HS Taxonomy field widget
  • Fixed #1136370 by fietserwin: Notice: Undefined index: exclude_tid in hs_taxonomy_hierarchical_select_children()
  • Fixed #1227518: PHP notices while uninstalling HS Taxonomy Views
  • Fixed #1230972: Export & import is broken
View change notices for this release
Official release from tag: 
7.x-3.0-alpha3