I get this error instead of the user lists in the autcomplete

An AJAX HTTP error occurred.
HTTP Result Code: 500
Debugging information follows.
Path: http://example.com/entityreference/autocomplete/field_partner/node/resid...
StatusText: Service unavailable (with message)
ResponseText: PDOException: SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'LIKE '%p%' ESCAPE '\\')
HAVING (bundle IN ('user'))
LIMIT 10 OFFSET 0' at line 1: SELECT users.uid AS entity_id, :entity_type AS entity_type, NULL AS revision_id, :bundle AS bundle
FROM
{users} users
WHERE (users. LIKE :db_condition_placeholder_0 ESCAPE '\\')
HAVING (bundle IN (:db_condition_placeholder_1))
LIMIT 10 OFFSET 0; Array
(
[:db_condition_placeholder_0] => %p%
[:db_condition_placeholder_1] => user
[:entity_type] => user
[:bundle] => user
)
in EntityFieldQuery->execute() (line 1117 of D7_path/includes/entity.inc).

Files: 
CommentFileSizeAuthor
#3 1276272-entityreference-bundle-hide.patch2.32 KBDamien Tournoud
PASSED: [[SimpleTest]]: [MySQL] 66 pass(es).
[ View ]

Comments

Status:Closed (duplicate)» Active

nope. the error still here.

Title:Autocomplete widget error for Users ReferenceDon't display bundle selection if the entity type doesn't have a bundle key
Priority:Critical» Normal
Status:Active» Needs review
StatusFileSize
new2.32 KB
PASSED: [[SimpleTest]]: [MySQL] 66 pass(es).
[ View ]

That's a good point: we should not display the bundle selection if the entity type doesn't have a bundle key.

Here is a patch for review.

Status:Needs review» Fixed

Merged into 7.x-1.x.

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.