I have used ckeditor for a long time with no problems, but with this current release the body disappears from all nodes when I try to edit or create them. Uninstalling fixes it, but I do not have an earlier version to roll back to. I tried updating all related files incluing the ckeditor files and it still does not work

Comments

I had this as well - along with all the other bug posts for the latest 6.x-1.7 release - I rolled back to 1.6 and everything was fine...

@johnTEN - you can always download previous releases here - http://drupal.org/node/606034/release

Status:Active» Postponed (maintainer needs more info)

Do you see any JavaScript errors in Firebug console ? Can you check if all request are correct in Firebug's Net tab.
What other modules do you have enabled.
Writing that "body disappears" you mean that your content is missing or there is no CKEditor for you textarea or what ?

For me this 6.x-1.7 release is completely broken. I couldn't get the editor to show up at all - anywhere. The toolbar options were not available within the module settings page - which might mean the js was not read... - perhaps all of this is related to the js related bug report?

@Chad_Dupuis you think about this bug #1325926: [D6] jQuery support problems ?

I'm getting the same error, I also updated CKEditor to v 3.6.2 so that isn't it.
There is a javascript error... details are below.

Thanks.

FYI: All the line numbers (i.e. :93) below are for ckeditor.js.

Uncaught TypeError: Cannot read property 'length' of undefined
j.add.init.o.on.sckeditor.js:93
a.event.on.mckeditor.js:6
a.event.fireckeditor.js:6
a.editor.fireckeditor.js:7
a.themes.add.buildckeditor.js:147
uckeditor.js:25
a.resourceManager.loadckeditor.js:23
a.scriptLoader.load.tckeditor.js:22
a.scriptLoader.loadckeditor.js:22
a.resourceManager.loadckeditor.js:23
uckeditor.js:25
sckeditor.js:25
a.scriptLoader.load.tckeditor.js:22
a.scriptLoader.loadckeditor.js:22
sckeditor.js:25
j.load.e.override.pckeditor.js:23
a.resourceManager.loadckeditor.js:23
a.scriptLoader.load.tckeditor.js:22
a.scriptLoader.loadckeditor.js:22
a.resourceManager.loadckeditor.js:23
j.load.e.override.pckeditor.js:23
j.load.e.override.pckeditor.js:23
a.resourceManager.loadckeditor.js:23
a.scriptLoader.load.tckeditor.js:22
a.scriptLoader.loadckeditor.js:22
a.resourceManager.loadckeditor.js:23
j.load.e.override.pckeditor.js:23
j.load.e.override.pckeditor.js:23
a.resourceManager.loadckeditor.js:23
a.scriptLoader.load.tckeditor.js:22
a.scriptLoader.loadckeditor.js:22
a.resourceManager.loadckeditor.js:23
j.load.e.override.pckeditor.js:23
(anonymous function)ckeditor.js:23
sckeditor.js:25
rckeditor.js:24
a.lang.loadckeditor.js:22
a.scriptLoader.load.tckeditor.js:22
a.scriptLoader.load.uckeditor.js:22
a.scriptLoader.load.vckeditor.js:22
a.scriptLoader.load.A.$.onloadckeditor.js:22

Hi again,
Just with a few more details from what I see.
The paths all seem correct. I have the CKEditor files in the libraries path, but the js links all seem correct to me.
I tried downgrading both to 6.x-1.6 and to CKEditor 3.6.1 and 3.6, but the same thing happens - I wasn't expecting that!
The page loads but the CKEditor is not showing.
Running the updates again didn't help.
Moving the CKEditor files to the module/CKEditor/CKEditor location didn't help.

Darren.

@dunwich42
please try use latest DEV version of CKEditor module for Drupal 6. There was a bug with jQuery and jQuery UI so maybe this issue is related with this. Please also check in Firebug Net tab if all request are correct.

I have solved this problem in the ckeditor configuration page.
In the default profile, in the Editor Aparience section is not selected a toolbar.
I click in one of this options and save the configuration:
Load sample toolbar: Basic | Advanced | Full
After that ckeditor works correctly.

I hope this help you with your problem.
Ciao

Uninstalling 1.7 and installing the latest dev version (2011-Nov-02) solved this issue for me.

Thanks @forges82, your answer solved my problem.
I probably should have looked further as I spotted the "File Browser type" setting missing yesterday.

Thanks all.

@forges82 & @dunwich42 after upgrade to 6.x=1.7 version did you run update.php (drupal script) and clear drupal cache after this? Please check this.

Hello @michal_cksource.
I ran update.php but i didn't clear drupal cache after.
When you run update.php you can see a message. This message says that drupal has lost a configuration profile and you must set it manually. The first time I ran update.php I didn´t see this message and this was my problem. With another drupal instance I saw the message and I solved the problem in the first drupal instance.

# 8 posted by by forges82
this solved my situation. Thanks so much!

#8 worked - thanks!

I commited changes to GIT. Please try latest DEV version.

#8 Worked for me to but it was the advanced profile. My advice would be to go in and save all configs even if no changes have been made.

I upgraded the module version and deployed with git after an upgrade.

Title:body disapearsbody disappears
Status:Postponed (maintainer needs more info)» Fixed

Looks like it is an issue with an old version, or with the update. Anyway it has been fixed.

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

Drupal 7.18 (and then 7.19) - CKEditor Module 7.x-1.12
Same problem (body disappear, may be after an update of core or CKEditor module)
In Apache access log was reported a Bad Request error (400) for every call of the CKEditor
#8 suggest the solution working for me: simply edit and then save without changes the CKEditor configuration profiles