Hi, i'm new at drupal and i'm getting the following error when updating to the lastest version of CKeditor:

An AJAX HTTP error occurred. HTTP Result Code: 200 Debugging information follows. Path: http://www.***.com.ar/es/update.php?id=7&op=do StatusText: OK ResponseText: Fatal error: Call to undefined function ckeditor_path() in /home/***/public_html/es/sites/all/modules/ckeditor/ckeditor.install on line 488

Then it takes me to another page that says:

The update process was aborted prematurely while running update #7003 in ckeditor.module. All errors have been logged. You may need to check the watchdog database table manually.

The log says:

Updated JavaScript translation file for the language...

TYPE locale
DATE Wednesday, November 2, 2011 - 20:15
USER admin
LOCATION http://www.***.com.ar/es/
REFERRER http://www.***.com.ar/es/update.php?op=start&id=6
MESSAGE Updated JavaScript translation file for the language Español.
SEVERITY notice
HOSTNAME 186.136.45.220

Would you please healp me or tell me where I can find a solution? I searched in the issues but didn't find anything about this.. Thanks!

Gabriela.

Files: 
CommentFileSizeAuthor
#7 1329980.patch406 bytesjherencia

Comments

Title:Hi, i'm[D7] Problem with CKEditor module update

Status:Active» Postponed (maintainer needs more info)

Did you have CKEditor enabled and did it work ok before update ? During update was CKEditor module enabled ?

It was previously installed and working ok. At the moment of the update it was disabled, and the site was offline/ maintainance.
Thanks for changing the title =)

Try update when CKEditor module is enabled.

Thank you michael_cksource. Enabling CKeditor and then running update worked.

Status:Postponed (maintainer needs more info)» Closed (fixed)

Status:Closed (fixed)» Needs review
StatusFileSize
new406 bytes

Following the process to upgrade from D6 to D7 it says that all non-core modules should be disabled to run update.php. That means that ckeditor could be disabled when updating from D6 to D7.

This patch fixes this problem.

Thx @jherencia for your patch. We will try it and use it ASAP.

Pardon my ignorance, but how (and when) does one apply the patch? I tried replacing the 6.x version of ckeditor with the 7.x version, then ran patch -p0 < 1329980.patch. It asked what file I wanted to patch, so just guessing, I said ckeditor.install. I got the message that the file was patched, then ran update.php.
After running update.php, I got the same AJAX error as usual (see above.)

Clearly, I am doing something wrong...

Thanks to you all for your help, I really apreciate it. Running the update while ckeditor is active solved the problem.

Hi.

I'm updating a site from D6 to D7. I also have a problem with update #7003 that may be related to this issue.

Whem I running update.php, I receiving this message:

ckeditor module
Update #7003
Failed: PDOException: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'mysite.ckeditor_input_format' doesn't exist: SELECT f.* FROM {ckeditor_input_format} f; Array ( ) in ckeditor_profile_load() (line 280 of C:\wamp\www\mysite\sites\all\modules\ckeditor\ckeditor.module).

The patch in #7 don't solve my question.

It's related? Any idea?

Tks

The patch I appended solves the problem with #7003 that breaks update.php.

@astutonet
It seems that ckeditor_profile_load, which is executed in update_7003, expects that ckeditor_input_format has been created previously, but somehow it doesn't.

It's a problem that needs to get fixed, but I think we should open another issue.

Ok.

The new issue is here.

Tks.

Status:Needs review» Fixed

@jherencia, really thx for patch, i commit it to GIT.

Greetings

Automatically closed -- issue fixed for 2 weeks with no activity.