Hi,

I've been trying to uninstall this module, but with no success. I've removed all the fields from the entities, but when I go to my module list, it says that Drupal Commerce depends on this module. It points me to the field list, but when I go there all it tells me is that the fields are used by "Rules configuration". I have not created any rules myself that use this module, I've checked all my entities and rechecked them and now I'm lost.... Any ideas?

Comments

Status:Active» Postponed (maintainer needs more info)

Category:task» feature
Priority:Normal» Critical
Status:Postponed (maintainer needs more info)» Needs work

I think the dev needs to warn people on the module page that uninstall is broken. If i would have known I had to manually edit my database to remove this, for lack of a better term, crap I wouldn't have wasted my time on it. I would recommend anyone looking at this module for their site to look elsewhere. I hate to be so negative but when three days of my precious time is wasted trying to make this thing work, I seem to get a bit upset. I understand that this works with other installs with great success, but they obviously are not going to attempt to remove it if it works.

I can verify that there are issues with uninstalling this module. Using the UI, this module is un-selectable on the uninstall screen because it states: Required by: Drupal (Field type(s) in use - see Field list). I'm seeing this behavior after turning on the module and adding meta tags to a single page. I'm not sure what I would have to do to remove this module but I sure am glad I tried it on a dev install.

Now that I have had time to calm down, I had to search my database for all items containing the words (Meta) and Meta Tags(quick). only after deleting those items and clearing the cache was i able to uninstall this module in a clean way. Beware that this module isn't the only one that uses these keywords though!! This should be a top priority for the dev to fix if he ever wants this module to be taken seriously.

Priority:Critical» Normal
Status:Needs work» Closed (works as designed)

If something, difficulties with uninstalling metatags_quick are related to the core changes (I guess in 7.6 or so), which made impossible uninstalling modules in case they provide field data.
In my opinion, this core change makes a lot of sense.