Hi seem to be having a problem with Commerce flat rate.

Installed it on my test site but when I switched the module on I get

Fatal error: Call to undefined function commerce_shipping_services() in /home/enchant/public_html/sites/all/modules/commerce_flat_rate/commerce_flat_rate.module on line 38

the only way to get the site back seems to be to re install on a clean database.
Next attempt switched on all of commerce and just shipping and shipping ui site looks fine but on the shop menu, shipping does not have any right arrow and drop down.
Then enabled flat rate and back comes the error message as above.
have now re installed again same thing happens.

The other day I did have it working on another site but the next day when I enabled some other modules I got

Fatal error: Call to undefined function commerce_tax_rate_load() in /home/lmpsolut/public_html/sites/all/modules/commerce_flat_rate/commerce_flat_rate.module on line 106

and again had to re install and have not got it to work again.
Anyone else having problems ?

Comments

The saga continues this morning I again re installed drupal into a new database, enabled the modules including shipping but not flat rate. all worked fine as soon as I put flat rate on, error on line 38 back again.
Have since downloaded new copies of shipping and flat rate and put on server re installed drupal again, this time all worked fine the shipping drop down menus worked, then went to enable another theme and back we go to
Fatal error: Call to undefined function commerce_shipping_services() in /home/enchant/public_html/sites/all/modules/commerce_flat_rate/commerce_flat_rate.module on line 38

used the back button to get back to site tried to add a flat rate service but got a warning

Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'commerce_shipping_ui_overview' was given in menu_execute_active_handler() (line 503 of /home/enchant/public_html/includes/menu.inc).

ignored this a tried to enter the flat rate but thn get

Fatal error: Call to undefined function commerce_shipping_service_load() in /home/enchant/public_html/includes/form.inc on line 3423

anyone got a large hammer

You need Commerce Shipping 7.x-2.x-dev to use Commerce Flat Rate. Please update your Commerce Shipping.

Thanks rfay I was using 2 on the other site but somewhere along the line must have pick 7.1 in error

thanks

Status:Active» Fixed

np. thought that was probably it.

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

It would help if this had a name of 7.x-2.x-dev to imply that it only works with v2 of shipping.