The link created to 'settings' in the dblog when the internal lightweight cron is run still has the D6 path. See attached screen shots. It should be admin/config/content/scheduler not admin/settings/scheduler

Patch coming up.

Jonathan

Comments

Status:Active» Needs review
StatusFileSize
new718 bytes

The change is in _scheduler_run_cron().
Patch against latest dev of 29th Nov.

Hi,
Would anyone like to confirm this simple patch? Then it can committed. It is a little frustrating not to be able to use the link in the dblog table entry, but this patch fixes it.
Jonathan

Hello Jonathan,

I tested this patch on a Drupal 7.10 installation and the settings link now shows up correctly on the dblogs page. Scheduler runs fine. This patch fixes any new links that will show up but not existing entries in dblog which is not a problem at all but some thing not to be confused for and also an FYI. Thanks for the patch.

Kiran

Status:Needs review» Reviewed & tested by the community

Thanks Kiran for your feedback.
I've set the status to RTBC - are you ok with this?

Jonathan
[edit: set status to RTBC]

Status:Reviewed & tested by the community» Closed (fixed)

Thanks @jonathan1055. This was committed!
http://drupalcode.org/project/scheduler.git/commit/d079cb4

Status:Closed (fixed)» Fixed

Thanks Rick. Tested this and I confirm the patch was committed and the dblog link is now correct.
Leaving as 'fixed' and will then be closed automatically in two weeks.

We have the first patch committed after a years gap - Scheduler is moving again!

Jonathan

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.