I have just updated the ckeditor code in several different drupal sites to 3.6.2 and to 1.8

In all these sites the teaser break has disappeared. I have tried clearing the cache and several other things but nothing has worked to bring the teaser break icons back.

This issue has occurred before, several versions earlier. I do not understand why it is still occurring and, what's worse, I cannot fix it.

I cannot find anyplace in the code where the plugins for the teaser breaks are actually loaded. Of course, there's lots of code so I may just not know where to look.

Any help is appreciated.

Comments

I don't know if it is the same issue, but it also happened to me, and there is now a feature in the "Editor appearance" of the configuration where you can add buttons to the menu and you can add the "teaser break" back.

Status:Active» Postponed (maintainer needs more info)

First of all u should have visible icon of Teaser Break in CKEditor profile on Toolbar drag&drop feature (it should be in the top toolbar - if not drag it there). Below this wizard u have plugins list where plugin with Teaser Break should be checked (enabled) - after this save profile and icon should appear in the toolbar.

After check it pls write does it help or not.

Greetings

Same problem
The teaser break icon has gone.
I can place it in the editor appearance configuration, the plugin is checked, but nothing appears on the editor.
It is still possible to set the teaser in plain text mode, but never with CKeditor

Reappeared for me after uninstall - reinstall

Status:Postponed (maintainer needs more info)» Active

I have the same problem (upgrade from a 2010 version to 1.9). Drupal breaks and my custom plugins buttons do not display in toolbar (even there are in the CKEditor profile settings page). I don't have time to investigate, however switch the editor to plaintext, then turn it on again and buttons appear. In Firebug, only when I turn on again CKEditor does it make http request to get plugin.js files and buttons.

Just a note that this is irreproducible on a clean install. So it might be something left in an update.

Another PS: this is reproducible on a clean install with loader = ckeditor_basic.js. This is caused by line 85 in includes/ckeditor.util.js:

if (typeof CKEDITOR.plugins != 'undefined'){

In the first time it check, CKEditor is not initialized yet and CKEDITOR.plugins = undefined. There is no problem with a standard load, or with editorOff/On later because at that time CKEDITOR.plugins is defined (type = a.resourceManager).

I don't have deep knowledge of CKEditor so I can't not suggest a fix. But I hope that issue is correctly identified.

Title:Teaser Break missing after update[D6] External plugins not work on ckeditor_basic.js loading method
Version:6.x-1.8» 6.x-1.x-dev
Status:Active» Needs review
StatusFileSize
new2.47 KB

I've attach patch with fix for this problem (i make patch from last DEV version).
Pls review this code and write does it help or not.

Greetings

Status:Needs review» Fixed

I commit this patch to GIT (diff)

Greetings

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

Title:[D6] External plugins not work on ckeditor_basic.js loading method[D6] External plugins not working in ckeditor_basic.js loading method