field_ui
AFAIK,

Title, Body, Tags are Fields.
"Term reference, Image, File, String .." are Field Types.
Field UI describe its column as "Field" column is confusing users..

Files: 
CommentFileSizeAuthor
#15 field_type.patch926 bytesdroplet
PASSED: [[SimpleTest]]: [MySQL] 39,159 pass(es).
[ View ]
#9 reroll-2.patch966 bytesdroplet
PASSED: [[SimpleTest]]: [MySQL] 36,814 pass(es).
[ View ]
#2 field_ui.patch950 bytesdroplet
PASSED: [[SimpleTest]]: [MySQL] 34,588 pass(es).
[ View ]
field_ui.patch508 bytesdroplet
FAILED: [[SimpleTest]]: [MySQL] 34,594 pass(es), 1 fail(s), and 0 exception(es).
[ View ]
field_ui.jpg95.95 KBdroplet

Comments

Status:Needs review» Needs work

The last submitted patch, field_ui.patch, failed testing.

Status:Needs work» Needs review
StatusFileSize
new950 bytes
PASSED: [[SimpleTest]]: [MySQL] 34,588 pass(es).
[ View ]

Works for me, but this is probably for the UX folks to RTBC.

Sounds fine to me, I will wait for another few reviews before marking this RTBC.

Seems reasonable, but then should we not rename the Widget column to Widget type as well?

I am not sure, for consistency yes - for clarity I don't think its needed. I am fine, either way.

@webchick: "should we not rename the Widget column to Widget type as well"
Strictly speaking, yes, but as @Bojhan said, I don't think this is needed nor really desirable.

The distinction between "field" and "field type" is crucial, but much less between "widget" and "widget type". That's because you don't really "create a widget of a given type" per se, you create a field and specify which widget [type] it uses, there is no such thing as standalone widgets, that would be important to differentiate from other standalone widgets of the same type.

Issue tags:+GoogleUX2012

Updating tags

StatusFileSize
new966 bytes
PASSED: [[SimpleTest]]: [MySQL] 36,814 pass(es).
[ View ]

One thing that we discussed during the entity representation format sprint was the introduction of #1346214: [meta] Unified Entity Field API. Everything (what we currently call fields and properties) would essentially be moved into one API - the Property API. So everything would be a property. I know that the term field has a long background in CCK and now in D7 as well. But technically speaking, property is a much more common word for what we are trying to describe here, IMO.

But maybe more importantly, since VDC is moving forward now, we have to avoid name collision and confusion between Field API's fields and Views' fields. They are not the same thing.

So maybe we should think about renaming Field API's fields to properties (which would go inline with #1346214: [meta] Unified Entity Field API) and let Views own the term fields.

Sorry to hijack the issue like this. Just wanted to highlight other discussions that is going on in parallell.

No, let's please not do that. To an end user, these are form "fields". they are not form "properties".

Status:Needs review» Reviewed & tested by the community

Ok this is good to go.

@dixon Sounds like a pretty bad idea.

Status:Reviewed & tested by the community» Fixed

Committed/pushed to 8.x, thanks!

Version:8.x-dev» 7.x-dev
Status:Fixed» Patch (to be ported)

This issue is tagged "needs backport to D7" and seems like it's reasonably safe to backport.

Especially since we're lucky and t('Field type') already appears in the codebase, so we aren't actually even adding a new string.

Status:Patch (to be ported)» Needs review
StatusFileSize
new926 bytes
PASSED: [[SimpleTest]]: [MySQL] 39,159 pass(es).
[ View ]

Status:Needs review» Reviewed & tested by the community

NIce! The only reason not to do this in D7 is it would invalidate tutorial instructions (e.g. books, blog posts, documentation pages). But I think I would support it despite authoring one of said books. ;) This is pretty "duh."

Setting to RTBC since this is a straight-forward port. Will leave it a couple of days, unless David commits it first.

Status:Reviewed & tested by the community» Fixed

Ok, didn't see any objections, so committed and pushed to 7.x. Thanks!

Issue tags:+7.15 release notes

Thanks, sorry I didn't get to this one myself.

It occurs to me that since this is a UI change, it would probably be worth mentioning in the release notes.... and I went ahead and added it to CHANGELOG.txt also: http://drupalcode.org/project/drupal.git/commit/49e806f

Automatically closed -- issue fixed for 2 weeks with no activity.

Issue summary:View changes

typo