Hi,

I'm using CKEditor 3.6.2 and CKFinder 2.1.1 on Drupal 7.12. CKEditor works fine, but I cannot get CKFinder to work properly. I have reinstalled the CKEditor module, library, and CKFinder multiple times, ensuring that I'm following every instruction to the last detail. But every time, when I "browse server", CKFinder ajax interface partially loads, seems to stall for a second, and then I receive this error in a new CKEditor-styled window that says:

It was not possible to properly load the XML response from the web server.

Raw response from the server:

Followed by my front page. The error message does not state the raw response.

Screen shot 1

After clicking "OK"

Screen shot 2

In addition, when I go to the Upload tab, browse and find a file, and click "Upload to server", the file field and browse button are replaced with a tiny frame within which my front page loads.

Screen shot 3

I know I haven't supplied any specific information, but I don't know what else to offer. If you can think of any other information I can find for you, please let me know. Thank you!

Comments

Category:bug» support
Priority:Major» Normal
Status:Active» Postponed (maintainer needs more info)

This kind of error usually shows when there is a syntax in CKFinder's config.php file or something change (is added) to response for CKFinder. In your case it looks like second case - http://drupal.org/files/Screen%20Shot%202012-02-22%20at%2012.12.14%20AM.png
Please also check in Firebug (Firefox add-on) if there are any errors.
Please also check your config.php file for syntax error.

Hey michal_cksource,

Thank you so much for such a quick response. It was so appreciated. I have been working on this and still can't find the problem. I've gone over the config.php several times and Firebug isn't reporting any errors, though I'm not great with anything outside of HTML / CSS, so there could easily be something where I don't know to look. I'll keep working on it and when I find out what's happening, I'll post here again. If you think of anything else to check, let me know, but I doubt there's too much you can do when the problem is so vague at the moment.

Thanks again for your help.

What theme do you use ?
Please use default Drupal theme and try to disable other modules. In this way you can find what breaks CKFinder.

I am also having this issues. I have, in efforts to fix the issue, upgrade to the latest version of Drupal 6. I also reinstalled CKEditor. It is the exact same issue. I am not having this issue with other sites on the same server. Just this one site. Any help would be great.

any conclusion or fix on this?

@guys please update CKEditor library to version 3.6.3 and CKFinder to 2.2.1 (latest stable versions).

Hi

I also got the same problem, but I sorted out. I have kept another ckeditor directory in the sites/all/modules renamed as (_ckeditor) so when I pressed the browse button It was taking the url of that directory ie .../_ckeditor/.... (I found out from firebug). I deleted the backup folder and it was done.

I ran into this issue when upgrading CKFinder to get it working with IE10. In my instance, the server was running an PHP extension called suhosin which was unhappy with the number of '../' in the require_once statement that includes filemanager.config.php file from CKEditor, and blocked the request because it thought it was a hack attempt.

The following error log entry was made suhosin:

ALERT - Include filename ('../../../../../modules/ckeditor/includes/filemanager.config.php') contains too many '../'

To tell if your server is running suhosin, go to the Status report page and click the "more information" link next to the PHP version number. If a text search on the page finds the text "suhosin", then you may have the same issue that I experienced.

I was able to fix the issue by adding the following line to the apache vhost configuration to disable the "max_traversal" setting:

php_value suhosin.executor.include.max_traversal 0

I could solve this problem by changing two files from my site:
. htacces
php.ini
__________________
.htacces
The changes you make in the. Htacces are:

suPHP_ConfigPath / home / folder_on_my_site / folder_where_my_php.ini

__________________
php.ini:
Changes you make to this file are in the following directives

safe_mode =
safe_mode_gid =
memory_limit = 512M
post_max_size = 50M
magic_quotes_gpc = Off
upload_max_filesize = 50M

Title:not possible to properly load the XML responseCKFinder: not possible to properly load the XML response (suhosin)
Status:Postponed (maintainer needs more info)» Fixed

Still happens with the latest CKFinder (2.4.x, or at least 2.2.1)?

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

Issue summary:View changes

Mixed up screen shots

This error usually is due to wrong configuration or syntax errors in CKFinder's ckfinder/config.php file.
Enable PHP error reporting to find out the origin of the problem:

/*
Uncomment lines below to enable PHP error reporting and displaying PHP errors.
Do not do this on a production server. Might be helpful when debugging why CKFinder does not work as expected.
*/
error_reporting(E_ALL);
ini_set('display_errors', 1);