If I add another product to the same product display - I get a select list of the two products when showing the product - but the price table is no longer shown.

IMHO it should show the price table for the relevant product chosen.. this would ofcourse require some client-side js to trigger on the product change.

Or it should show a product table for each product in the product display.

Comments

Status:Active» Postponed (maintainer needs more info)

Just tried this in a commerce kickstart install without any issues, added 2 products with price tables to 1 display and product switcher works just fine.

and the price table updates for you?

See here: http://flowersup.fosshosting.com/content/timian

The price table never updates - even though str.2 has only 1 price (20 DKK which will then be added 25% VAT) from 1 to -1 in quantity.

Odd the price table weren't shown at all before, but I don't seem to be able to reproduce that behavior right now.

Yup, no problem at all with the module, could you try the -dev version?

I need to push a 1.1 version someday

I updated to .dev version - and it still doesn't work. AFAIK it needs a JS side, to update the page upon change of selector.

Version:7.x-1.0» 7.x-1.x-dev

Price display refresh is something handled by commerce itself, no need of any external js.

Which version of commerce are you using?

Latest (1.2) just downloaded.

With the information provided I can't do much more here, you can test it yourself, install a commerce kickstart somewhere, download price table module and check this feature.

Maybe there are some module incompatibilities but I'm going to need much more information that the provided here, without a consistant way to reproduce this issue, it's not likely that a fix can be provided.

So you are saying, that your drupal commerce kickstart install (which is the same as mine) does not have this problem?

I'll gladly give you an ssh account on the machine it's running on (it's a test machine - but we use it for other tests as well :) - with rights to modifying files in that sites folder, if that can help. Just email me at kl@vsen.dk