I've set up several sign-up content types and created a few dozen nodes.
When I visit the admin page at admin/content/signup I get the following messages:

Notice: Undefined property: stdClass::$language in _signup_date_get_node_scheduler() (line 112 of [...]/sites/all/modules/signup/includes/date.inc).
Warning: array_push() [function.array-push]: First argument should be an array in date_formatter_format() (line 450 of [...]/sites/all/modules/date/date.module).

The first message goes away if I change the second line of code in _signup_date_get_node_scheduler as follows:
if (!empty($node->{$field['field_name']}[isset($node->language)?$node->language:'und'][0]['value'])) {

I don't know if this is related: in this admin listing page, all nodes are showing up as closed for signup, although they are actually all open (and signing up works). Only one of the nodes is in a content that has a date field, which has been set to be used by signup; the other nodes don't have any date field.

Using the latest Drupal 7.2 and Date 7.x-2.0-alpha3.

The attached patch resolved my problem.

Hope, it will help you, too.

Comments

Category:task» bug
Priority:Major» Normal
Status:Fixed» Needs work

@Hardik C: Thanks for your recent flurry of activity here. However, please read the Issue queue handbook, in particular, the description of the Status field and how it's used. "Fixed" means the change has been committed "upstream". You're posting a patch for review and consideration by the module maintainers so we can decide if it "needs work" or should be committed, at which point we mark the issue "fixed". ;)

Also, sounds like you're reporting a bug. And since it's not crippling your site, it's only "normal"...

Finally, looking at the patch, it appears you've uploaded the wrong file. ;) Doesn't have anything to do with the signup.module.

Please upload the right patch and set the status back to "needs review".

Thanks,
-Derek

@dww:

Agree!! Sorry for the wrong patch which had been attached!!

This patch is related to answers module. And I posted a new bug with its solution.

Regards,
Hardik

Project:Signup» Answers

Version:7.x-1.x-dev» 7.x-3.x-dev
Status:Needs work» Closed (won't fix)

Thanks for the update on this. All of the fixes look right on target ... and somewhere along the path, they have already been incorporated in the current version, which is 7.x-3.x-dev.

I'm marking this as already fixed ... but please let me know if you have issues with 7.x-3.x-dev.