Hi there,

I am hoping there is a quick fix for this issue. I can't recall which version broke, but the Status and priority fields in both Tasks and Tickets return a "Broken/missing handler error. I have tested other fields, but not all of them... See screenshot for the error.

Any tips on how to recover from this issue?

Also, this system has been running for years. I have not tried a clean install and I have many, many modules installed. I am running D6.25 and the most current version of Storm (6.x-2.0).

The issue has been present for several versions of the module, I have just been living with it... Now need to fix it so I can filter on open tickets only...

Thanks in advance!

Oh, and by the way, LOVE Storm. You guys have done a good service to humanity at large!

Jamie

Files: 
CommentFileSizeAuthor
#37 storm-1508998-mkoo-views-screen.png44.71 KBm.koo
#32 storm-broken-missing-hand.png22.11 KBcopeasetic
#30 storm-1508998-27-mkoo.patch14.87 KBm.koo
PASSED: [[SimpleTest]]: [MySQL] 2,614 pass(es).
[ View ]
#28 storm-removed_trailing_whitespace-1508998-mkoo.patch622 bytesm.koo
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch storm-removed_trailing_whitespace-1508998-mkoo.patch. Unable to apply patch. See the log in the details link for more information.
[ View ]
#22 storm-1508998-0-mkoo.patch14.87 KBm.koo
PASSED: [[SimpleTest]]: [MySQL] 2,614 pass(es).
[ View ]
#20 storm-1508998-0-mkoo.patch14.78 KBm.koo
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch storm-1508998-0-mkoo_1.patch. Unable to apply patch. See the log in the details link for more information.
[ View ]
#16 storm-1508998-0-mkoo.patch14.78 KBm.koo
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch storm-1508998-0-mkoo_0.patch. Unable to apply patch. See the log in the details link for more information.
[ View ]
#14 storm-1508998-0-mkoo.patch14.87 KBm.koo
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch storm-1508998-0-mkoo.patch. Unable to apply patch. See the log in the details link for more information.
[ View ]
#11 storm-1508998-0-jgb.patch14.05 KBjuliangb
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch storm-1508998-0-jgb.patch. Unable to apply patch. See the log in the details link for more information.
[ View ]
#9 storm-1508998-0 jgb.patch14.05 KBjuliangb
FAILED: [[SimpleTest]]: [MySQL] Fetch test patch: failed to retrieve [storm-1508998-0 jgb.patch] from [drupal.org].
[ View ]
#7 storm-1508998-0.patch15.42 KBm.koo
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch storm-1508998-0.patch. Unable to apply patch. See the log in the details link for more information.
[ View ]
storm-status-broken-handler.png10.46 KBcopeasetic

Comments

Status:Active» Postponed (maintainer needs more info)

Things to check:
- Have you cleared the site cache and views cache? Even if you've done so already, please do so two times again (sometimes takes a couple of times to clear everything).
- Have you tried removing the field and adding it again?

If those don't work, post back.

I have cleared the caches and confirmed the tables were actually truncated, so drush cc is clearing the cache properly.

I have remove the fields and attempted to re-add them. I have also created brand new views in an attempt to start from scratch and still receive the broken handler error. Is it possible that the code that exposes those fields to the views module is missing or malformed?

Is it worth mentioning that I am running views 6.x-3.0, Views Accordian 6.x-1.5, Views Bulk Operations (VBO) 6.x-1.13, and Views Slideshow 6.x-3.0?

Thanks again for your help with this!

Jamie

Status:Postponed (maintainer needs more info)» Active

Are you able to use Views 2 rather than Views 3? That may be the issue.

Otherwise, I hope to test this myself soon.

hey folks,

I just wanted to chime in and maybe contribute some help/info regarding this issue.

I think I was able to track this down to some naming inconsistencies with the views-integration. (I'm using storm-6.x-2.x-dev / views-6.x-2.16)

as far as I know there was a change concerning the integration of the storm_attribute module into the "main" storm module.

so now the views-handlers inc files reside in the main storm modulefolder. they are named "storm_handler_*.inc", which is correct, though the handler-classes inside these files are named "stormattribute_handler_*".

as far as i can tell, by default the handler classes should reside in a file thats named the same.
and the views 2 api help-docs describe the handler naming-conventions like this: [module]_handler_[type]_[tablename]_[fieldname]

so, since there is no module called "storm_attribute" or "stormattribute" anymore, the views api can't find the defined handlers.

taken the stormorganization.views.inc as an example I was able to fix the issue by replacing occurences of "stormattribute" with "storm" (in context of the handler definitions of course). I also changed the handler's classnames from "stormattribute_*" to "storm_*" (class-naming like in storm_handler_field_operation.inc)

I applied this procedure to all the *.views.inc files in various storm-modules and the "broken/missing handler" messages in the views-ui were gone.

I will test this further and will come back to you if I can gather more info regarding this issue / my fixing-approach

hope I could help!

regards,
michael

Any chance of a patch with the change that you think works?

hey julian,

sure - will provide a patch this afternoon!

bye

Status:Active» Needs review
StatusFileSize
new15.42 KB
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch storm-1508998-0.patch. Unable to apply patch. See the log in the details link for more information.
[ View ]

hello julian,

here's the patch to hopefully fix this. pls review and post back. thank you!

bye

Status:Needs review» Needs work

The last submitted patch, storm-1508998-0.patch, failed testing.

Status:Needs work» Needs review
StatusFileSize
new14.05 KB
FAILED: [[SimpleTest]]: [MySQL] Fetch test patch: failed to retrieve [storm-1508998-0 jgb.patch] from [drupal.org].
[ View ]

Not sure whether this will work - haven't tested, but did a text replace on the patch to be rooted in the Storm directory.

Status:Needs review» Needs work

The last submitted patch, storm-1508998-0 jgb.patch, failed testing.

Status:Needs work» Needs review
StatusFileSize
new14.05 KB
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch storm-1508998-0-jgb.patch. Unable to apply patch. See the log in the details link for more information.
[ View ]

I think that was because of the space in the file name.

Status:Needs review» Needs work

The last submitted patch, storm-1508998-0-jgb.patch, failed testing.

@m.koo - would you be able to repatch from within the Storm directory please? Looks like my attempt to alter the patch manually didn't work.

Status:Needs work» Needs review
StatusFileSize
new14.87 KB
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch storm-1508998-0-mkoo.patch. Unable to apply patch. See the log in the details link for more information.
[ View ]

here you go - repatched with relative paths

Status:Needs review» Needs work

The last submitted patch, storm-1508998-0-mkoo.patch, failed testing.

Status:Needs work» Needs review
StatusFileSize
new14.78 KB
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch storm-1508998-0-mkoo_0.patch. Unable to apply patch. See the log in the details link for more information.
[ View ]

re-rolling again ; patch now created with "--no-prefix"

Status:Needs review» Needs work

The last submitted patch, storm-1508998-0-mkoo.patch, failed testing.

Thanks for persevering - I'm not sure why the bot is complaining at the moment, but a couple of quick things to check come to mind:
1) I committed some patches to Storm yesterday - are you on the latest version?
2) Anything else in http://drupal.org/node/707484 that is different to what you're doing?

Not to mention - your welcome! I'm always happy to give something back as far as I can. Especially for a great set of modules like storm! :)

ad 1) I updated to latest dev, but my changes would still apply
ad 2) The patches I posted to this issue before were generated via Eclipse/Egit. I remade a new one from the shell. Will post it subsequently. Hope it works.

Status:Needs work» Needs review
StatusFileSize
new14.78 KB
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch storm-1508998-0-mkoo_1.patch. Unable to apply patch. See the log in the details link for more information.
[ View ]

Status:Needs review» Needs work

The last submitted patch, storm-1508998-0-mkoo.patch, failed testing.

Status:Needs work» Needs review
StatusFileSize
new14.87 KB
PASSED: [[SimpleTest]]: [MySQL] 2,614 pass(es).
[ View ]

Status:Needs review» Needs work

The last submitted patch, storm-1508998-0-mkoo.patch, failed testing.

I'm sorry, but I don't get it.

On my local dev environment the patch applies without problems. I applied it on different drupal/storm installations.
Generated the patch exactly like http://drupal.org/node/707484 suggests/describes.

Is there a problem because the patch includes changes to multiple files?

Can you please review the patch file and tell me if I'm missing something?

EDIT: I meant the patch-file from post #22

Version:6.x-2.0» 6.x-2.x-dev

Let's see if this helps - changing version to -dev.

Status:Needs work» Needs review

#22: storm-1508998-0-mkoo.patch queued for re-testing.

That works!

One comment from the review - there is trailing whitespace on one line.

+++ b/stormorganization/stormorganization.views.inc
@@ -302,13 +302,13 @@ function stormorganization_views_data() {
+      'storm_handler_field_attributes_domain' => array(  ¶

@copeasetic - please can you test and report whether this solves your problem too?

StatusFileSize
new622 bytes
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch storm-removed_trailing_whitespace-1508998-mkoo.patch. Unable to apply patch. See the log in the details link for more information.
[ View ]

Changing to -dev version, ok ... should have noticed this - DOH!!

The whitespace obviously slipped in somehow. Attached another patch to remove that.

Status:Needs review» Needs work

The last submitted patch, storm-removed_trailing_whitespace-1508998-mkoo.patch, failed testing.

StatusFileSize
new14.87 KB
PASSED: [[SimpleTest]]: [MySQL] 2,614 pass(es).
[ View ]

uploaded wrong file. damn.

Status:Needs work» Needs review

StatusFileSize
new22.11 KB

Hello there,

I have applied the patch and it looks to have solved half of the issue. The status and priority fields are now available via views, however, they are still not available to filter against (please see attached image).

I am planning to review the patch more carefully and confirm your changes have been in fact applied as I encountered a couple of git apply messages, so I can not confirm with 100% certainty that the patch applied properly.

As an FYI I applied the above patch via git from the storm root directory using "git apply -v storm-1508998-27-mkoo.patch.

Please accept my thanks for the all the work done thus far on this issue. I most appreciate it!

Priority:Normal» Major

Hello,

I had the same problem and applied your patch from #30 and run update.php:

- I can now choose ticket status as a field in the view, the "broken handler" error disappears,
- When I change something on the filter settings of the view f.e. I had an "assigned"-filter, then I get the following error message:

"An error occurred at /admin/build/views/ajax/add-item/_name_of_view_overview/default/filter.
Error Description: 500: Internal server error. Please see server or PHP logs for error information."

This message is displayed when I want to add a new filter on a new or existing view or when I want to modify an existing filter after clicking "Add" or "Cancel" on the filter settings.

When I remove the patch everything is back as to how it was before.

I use
- PHP 5.2.9
- Drupal Commons 2.6 with Drupal Core 6.25

Thank you!

Laurent

Subscribe

Thank you so much m.koo for the patch. After patching, broken handler messages disappeared from Fields. Thank you!

Then when trying to Filter by project status, error:
Fatal error: Call to undefined function stormattribute_attributes_bydomain in storm_handler_filter_attributes_domain.inc

Searching for a solution, I landed on this thread.

Based upon that information, I modified the function name located in storm_handler_filter_attributes_domain.inc:

from:
stormattribute_attributes_bydomain

to:
storm_attributes_bydomain

Status:Needs review» Needs work

Looks like we have a part solution in the current patch here, with a suggestion for how to solve the rest of the problem.

Could someone update the patch to do both and hopefully we can get this one in soon?

StatusFileSize
new44.71 KB

hey guys,
sorry for the late reply, but i was kind of drowning in work the last weeks...
anyhow...

i tried, but i cannot reproduce the issues you keep having after you applied the patch from #30 ....
i created the patch via "diff" from the shell and applied it (multiple times for testing) via eclipse and also from the shell via "patch -p1"
(all relative to the storm-module folder....)

@bradspry : your welcome ;)
you said

Based upon that information, I modified the function name located in storm_handler_filter_attributes_domain.inc

but when you take a look at the patch-file, you will notice that this exact change is part of the patch. so when you've applied the patch
correctly, you shouldn't have that line anymore in that file....hm.....

@lorenz @copeasetic:
i am also sorry, that the patch didn't completely work for you, but as i said to @bradspry - did you apply the patch correctly?

with the changes from the patch i can add/edit/expose filters on various storm-fiels (also ticket-fields) and use storm-relationships within views without any errors....

@juliangb : do you encounter troubles/errors with that patch too? or can someone chime in, that has NO problems with that patch besides me? :D

attached is a views-screenshot of working relationships/sorting/filters/arguments

Status:Needs work» Needs review

#30: storm-1508998-27-mkoo.patch queued for re-testing.

Status:Needs review» Fixed

I reread and tested this patch, and found to solve the issue.

Committed to 6.x-2.x and 7.x-1.x branches.

Thanks all.

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.