Hi everyone,

I set up meta tags quick for my company's site www.isovera.com and the meta tag description and keywords are showing up on every page except the front page. The keywords and description are entered into both the Global and the Global front page areas. Any advice?

Thanks,

- Jon

Comments

Try to use path-based meta tags for the path /node instead of global keywords and description

Oh! well come on! some help please. I've tried to set up this module but everything works fine except front page. Does not show any meta tag, nor description nor keyword, nor... i 've installed this module in other pages and works fine but don't know what's going on right know. My theme is a boilerplate and i'm using flexslider also. There's could be some conflict?? i will appreciate some help...thanks in advanced!

Oh! well come on! some help please. I've tried to set up this module but everything works fine except front page. Does not show any meta tag, nor description nor keyword, nor... i 've installed this module in other pages and works fine but don't know what's going on right know. My theme is a boilerplate and i'm using flexslider also. There's could be some conflict?? i will appreciate some help...thanks in advanced!

i've tried to use path-based meta tags but still don't work...

I'm also seeing the same issue. Subscribing....

Are path-based meta tags enabled? What meta tags are attached to path-based?

I can confirm similar behavior on version 7.x-2.5:

* I have "keywords" and "descriptions" both attached to path-based
* Under Administration » Configuration » System » Site Information, I have default front page set to "front"
* Meta tags appear correctly for all paths except front page - I simply enter "front" as the path, but it does not work

ok - figured it out. It turns out I had defined my front page as a node. So, it wasn't appearing as a path.

Here is the simple solution Meta tags on front page

Status:Active» Closed (duplicate)