In order to use the font scale mixin the modular-scale gem must be installed, it is not entirely clear from the documentation that this is indeed a separate step (gem install modular-scale). Also, require 'modular-scale' must be added to config.rb. Since font-scale is defaulted to true, the documentation should be updated and the require line should probably be added to the starter kit's config.rb.

Using compass is daunting enough for people who don't normally use ruby or the command line - and getting an error right away can scare people into thinking it is too complicated.

Yay for Compass + Drupal! Thanks.

Comments

Status:Active» Postponed (maintainer needs more info)

So here's the thing, I think the error you're getting is an error that I was seeing but couldn't backtrace with an old version of the gem, but wasn't a real error, it was one I was throwing. The way I set up the Aura gem, by simply requiring Aura you should be getting Susy, Modular Scale, and I believe Sassy Math as well (when you install the Aura gem, those come with it; the grid is Susy powered). If you could A) tell me which version of the gem you currently have installed and B) update your gem to see if that solves the issue of needing to require modular scale, that'd be great.

Status:Postponed (maintainer needs more info)» Closed (won't fix)

Due to the direction change in Aurora, I'm marking this closed (won't fix)