Last updated August 22, 2013. Created by JohnAlbin on May 18, 2012.
Log in to edit this page.

If you followed the directions for creating a sub-theme, you will NOT have edited any files in the Zen directory and should only have modified files in your sub-theme's directory. So upgrading to the latest Zen will be easy.

  1. If you are replacing the Zen theme on a live server, place your site in maintenance mode.
  2. Download the latest Zen from http://drupal.org/project/zen
  3. Remove the zen folder from your Drupal installation.
  4. Unpack the downloaded file and place the new zen folder in your Drupal installation in the same place as the previous zen theme used to be.
  5. Turn off maintenance mode.

Upgrading Zen from 7.x-5.0 to 7.x-5.1

There are a handful issues that were fixed in 7.x-5.1 that may require you to update your sub-theme. Sub-theme authors should check each of the issues in Zen 7.x-5.1’s change records and modify their sub-theme if appropriate.

Zen 7.x-5.3

Zen 7.x-5.3 was a broken release; See Styling for messages, form items, "more" links, and pagers missing from Zen 7.x-5.3. Skip directly to 7.x-5.4. If you are already on 7.x-5.3, you can upgrade to 7.x-5.4 without additional steps.

Upgrading Zen from 7.x-5.1 to 7.x-5.4

There are a handful issues that were fixed in 7.x-5.4 that may require you to update your sub-theme. Sub-theme authors should check each of the issues in Zen 7.x-5.2’s change records and Zen 7.x-5.4’s change records and modify their sub-theme if appropriate.

Upgrading Zen from 7.x-5.1+X-dev to 7.x-5.2

Zen 7.x-5.2 was a special release designed for sites using the -dev version of Zen after 7.x-5.1 was released. The -dev version used a class naming convention that was changed in 7.x-5.4. Sites using the -dev version can upgrade to 7.x-5.2 much easier then they can to 7.x-5.4.

There are a handful issues that were fixed in 7.x-5.2 that may require you to update your sub-theme. Sub-theme authors should check each of the issues in Zen 7.x-5.2’s change records and modify their sub-theme if appropriate.

Once you have successfully upgraded to 7.x-5.2, you can upgrade to 7.x-5.4 by checking each of the issues in Zen 7.x-5.4’s change records and modifying your sub-theme.

Looking for support? Visit the Drupal.org forums, or join #drupal-support in IRC.