I got mysql connection lost error during heavy load on website. it seems on random. i found this error in watchdog table.

i did n't get any solution for it.

| 16160418 |     0 | php  | %message in %file on line %line. | a:4:{s:6:"%error";s:7:"warning";s:8:"%message";s:171:"mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Lost connection to MySQL server at 'reading initial communication packet', system error: 110";s:5:"%file";s:76:"/includes/common.inc(1695) : eval()'d code";s:5:"%line";i:10;} |        3 |      | https://www.example.ca/                                               |                                                                           | 10.172.80.20    | 1339005945 |
| 16160283 |     0 | php  | %message in %file on line %line. | a:4:{s:6:"%error";s:7:"warning";s:8:"%message";s:171:"mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Lost connection to MySQL server at 'reading initial communication packet', system error: 110";s:5:"%file";s:76:"/includes/common.inc(1695) : eval()'d code";s:5:"%line";i:10;} |        3 |      | https://www.example.ca/webfm_send/513                                 | https://www.example.ca/                                              | 23.17.181.146   | 1339005854 |
| 16160278 |  1025 | php  | %message in %file on line %line. | a:4:{s:6:"%error";s:7:"warning";s:8:"%message";s:171:"mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Lost connection to MySQL server at 'reading initial communication packet', system error: 110";s:5:"%file";s:76:"/includes/common.inc(1695) : eval()'d code";s:5:"%line";i:10;} |        3 |      |https://www.example.ca/fr/home                                        | https://www.example.ca/home                                          | 174.142.119.125 | 1339005852 |
| 16159918 | 10431 | php  | %message in %file on line %line. | a:4:{s:6:"%error";s:7:"warning";s:8:"%message";s:171:"mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: Lost connection to MySQL server at 'reading initial communication packet', system error: 110";s:5:"%file";s:76:"/includes/common.inc(1695) : eval()'d code";s:5:"%line";i:10;} |        3 |      | https://www.example.ca/home

MYSQL SERVER is different from Apache SERVER.

every thing is working fine if i click on above URLs. but in watchdog i got same problem.