Hello.

I am in the process of theming my site with AT Panels Everywhere.

I created a Home Page content type and created a Home Page variant in Node template. I have the Selection rule as Node: type as Node being viewed is type "Home Page". I've created Mini panels and added them and other content in the Layout regions of that variant. I created a Home Page via 'Add Content' in order to see the result.

The issues are:

1) The content I added to the Layout regions in the Home Page variant show up as stacked up on the left in the Preview and on the Home Page itself, not in the Left, Center, and Right as it shows in the layout. I have the Disable Blocks/regions checked for both the Default site template -> ATPanels Everywhere Site Template AND for the Home Page variant.

For the Home Page variant, I have Template as 'Let the system choose' since I had already selected 'Layout for home page in default' -> 'AT Panels Everywhere site template' as the Current Layout via Manage Display in the Content Type screen.

*** EDIT: Selecting the 'Layout for home page in default' via the Content Type page was made just prior to creating this support issue. I just noticed that gave errors that went away when I set the default back to 'None'.

2) I don't see the resulting layout from the default AT Panels Everywhere Site Template (menu, etc.) on the Home Page that was created from 'Add Content'.

Q: What might be the issues be?

Thanks.

Comments

This is quite hard to follow, and I am not sure I can answer it correctly without seeing the actual issue.

Could you add some screenshots of the various administration pages etc so I can see the settings and issues you are describing.

Thanks for your reply, Jeff.

In my previous reply, I was listing the settings for both the AT Panels Everywhere template as well as the newly-created Node template variant named 'Home Page'. I also created a Home Page from Add Content so I could see the output from the Home Page variant. I see the content (mini panels, etc.) on that Home Page content page that I added via Panels, but I don't see the other regions on that page that were suppose to have come from the AT Panels Everywhere template. Plus, the content that I do see on the Home Page that came from the variant is there, but the layout is not correct.

For the Home Page variant, I selected the AT Responsive Panels - 3 column layout and added content in the Left, Center and Right regions. When I preview that variant within Panels, and when I load the actual page, instead of the content from those 3 regions being side-by-side horizontally as dictated by the layout, they are lined up 'vertically' in that same order.

I did go back to the AT Panels Everywhere template and added content to check that preview, and I saw the following error messages:

~~~~~~~~~~~~~~~~~~
Notice: Undefined property: ctools_context::$placeholder in ctools_context_replace_form() (line 1305 of /.../site/sites/all/modules/ctools/includes/context.inc).
Notice: Undefined property: ctools_context::$placeholder in ctools_context_replace_form() (line 1305 of /.../site/sites/all/modules/ctools/includes/context.inc).
Notice: Undefined property: ctools_context::$placeholder in ctools_context_replace_form() (line 1305 of /.../site/sites/all/modules/ctools/includes/context.inc).
Notice: Undefined property: ctools_context::$placeholder in ctools_context_replace_form() (line 1305 of /.../site/sites/all/modules/ctools/includes/context.inc).
Notice: Undefined property: ctools_context::$placeholder in ctools_context_replace_form() (line 1305 of /.../site/sites/all/modules/ctools/includes/context.inc).
Notice: Undefined property: ctools_context::$placeholder in ctools_context_replace_form() (line 1305 of /.../site/sites/all/modules/ctools/includes/context.inc).
~~~~~~~~~~~~~~~~~~

and below that, I see the following:

~~~~~~~~~~~~~~~~~~
Page content (%content)
Page title
Dummy page title
Page content

Dummy page content

~~~~~~~~~~~~~~~~~~

I am unsure if this error is causing the problem with the Home Page variant's content display and what might be causing this error.

Thoughts?

Thanks.

@drupert55 I had similar layout and visibility issues and I've fixed it by replacing my Adaptive Theme version.

AT Panels everywhere (ATPE) seems to play nice only with the 7.x-3.x version of Adaptivetheme as specified in ATPE's drupal page.

See if you have the right version, it might save you some serious time.

Yes, run the absolute latest DEV versions of everything for AT Panels Everywhere.

Thanks for your replies, jjclint and Jeff.

Maybe, that may be my issue - interpretation of the statement on ATPE's page:

'Please use the 7.x-3.x version of Adaptivetheme as the base theme.'

Since I have only dealt with themes that had no dependent component themes (except with Fusion briefly), maybe the setup is wrong.

Now that I look at that statement, exactly, what does it mean in terms of setup relative to ATPE?

Also, does having other themes enabled, other than the Admin theme, present any undesirable issues?

Thanks.

Now that I look at that statement, exactly, what does it mean in terms of setup relative to ATPE?

Frankly I have no idea what you are really asking here.

Also, does having other themes enabled, other than the Admin theme, present any undesirable issues?

Impossible to answer, I do not know what other themes or modules are doing. In general, and in my experience, no. They just add clutter.

same error and issue, even with everything related to Panel & Panel everywhere is the latest Dev version..

same error and issue as what?

The content I added to the Layout regions in the Home Page variant show up as stacked up on the left in the Preview and on the Home Page itself, not in the Left, Center, and Right as it shows in the layout. I have the Disable Blocks/regions checked for both the Default site template -> ATPanels Everywhere Site Template AND for the Home Page variant.

I think I'm having the sam problem over here. I have a couple of variants for my site template, the one I'm discussing being the Control Panel variant. I've understood that for the "Default site template" we're to use the "AT Panels Everywhere" layout. Great, got it.

As you can see in my layout attached, I've added some standard page elements as well as some menus that I'm using throughout the control panel. Make note of the two in the "Sidebar second" region.

When I view the page on the desktop, the panel is not arranged as described in the layout-- it appears stacked. I've attached a screenshot there, too.

I took a look at the "Panels & Gpanels" tab in the "AT Panels Everywhere" theme settings and all look fine there-- I haven't made any changes. I would expect them, on a desktop with the browser opened plenty wide, for the page to appear as arranged in the layout.

What am I missing?

I put together this screencast so you can see what I'm up to:
https://dl.dropbox.com/u/4770698/Drupal-org/AT%20Panels%20Everywhere%20S...

As a side note. I've been using Zen for years. And I first used Panels Everywhere last summer. To be able to "adaptify" all this with your theme would be amazing. The configuration interface looks mighty impressive. Thank you for your work on this.

--- UPDATE ---

I am also getting this "stacked" behavior when using the "AT Three column 25/50/25" layout. The Left, Center and Right regions all appear stacked when viewing on the desktop with at least 960px of width in the view port.

Have you saved the theme settings for AT Panels Everywhere at least once?

Can you take a screen shot of the Summary and attach it here - I can't see it all in the screencast.

The screencast is great, thanks a lot. To my mind the layout CSS is not loading, or has not been generated (by saving the theme settings once or more if you change it).

If saving the theme settings does not solve the issue, then I would ask if you can zip up the whole site and database and put it somewhere I can get this and install locally so I can reproduce it.

The Panels and Gpanels stuff in theme settings - that controls all the other AT Panels layouts, what you might put inside the content region as say a mini panel, or Panelize a node with etc etc. The main layout is controlled by the Standard/Tablet/Smartphone page layout settings - I think I can make this more clear with better descriptions and help text in the theme - thanks for pointing out its a bit confusing, feedback like that is gold.

StatusFileSize
new110.93 KB

1. Summary screenshot attached.

2. Just to be sure we're talking about the same configuration page, I went to admin/appearance/settings/at_panels_everywhere and clicked on the Save Configuration button one more time for good measure.... hey... it works now! Weird. I swear that I saved that configuration page before!

3. Ah, so it's like there are two levels of adaptive going on.. one is for the wrapper (Panels Everywhere) and one is for the content (Panels). Is that right?

You might get a screencast setup to illustrate the setup and concepts. This is truly an amazing theme for Panels folks. And considering that panel-centric layouts are going to be a big part of Drupal 8 and you are the Drupal 8 Design Initiative owner, getting people hip to this paradigm seems like priming the pump.

This is great!

The Panels and Gpanels stuff in theme settings - that controls all the other AT Panels layouts, what you might put inside the content region as say a mini panel, or Panelize a node with etc etc. The main layout is controlled by the Standard/Tablet/Smartphone page layout settings - I think I can make this more clear with better descriptions and help text in the theme - thanks for pointing out its a bit confusing, feedback like that is gold.

That took me about 2 hours to figure out... maybe this can be added to the project page or similar. :)

Funny thing is, I tried this theme a couple other times and messed with it for a couple minutes before moving on. When I made the connection that I could modify the layouts dimensions, how they stack, etc via the theme settings page for both PE layout and the others... my jaw dropped!

I agree, this is amazing. :)

...
Now if we could only get these layout settings out of the theme settings and apply them somehow PER panel/variant... so I could have say standard layout of 50/25/25 for 1 page/variant and 25/50/25 for another..

Agree, if we could get the layout entirely into Panels and Page Builder that would be ideal!

Issue summary:View changes

Re-selected the default layout as 'None' via the Content Type for Home Page.