Just installed the at_panels_everywhere and error came out after Enabled and Set Default.

Fatal error: Call to undefined function at_get_setting() in /home/victori2/public_html/sites/all/themes/at_panels_everywhere/template.php on line 82

Comments

Category:bug» support

Did you install the base theme?

From the project page: Please use the 7.x-3.x version of Adaptivetheme as the base theme.

http://drupal.org/project/adaptivetheme

already installed...

AT commerce theme can use without problem yet..

Status:Active» Closed (cannot reproduce)

Assuming fixed.

If you have the base theme installed, as you say you do, and its actually the right version, then two functions would have to fail: require_once and drupal_get_path, is this what you say is happening?

Or you modified the info file and removed the base theme declaration.

Suffice to say, in most regards, this is impossible unless you have done something to change it.

i had this too. i deleted an older version of 3.x and downloaded rc6 have:

[10-Jul-2012 16:01:14] PHP Fatal error: Call to undefined function at_get_setting() in /mnt/www/WORKSPACE_DRUPAL/EIGENE_PROJEKTE/test_2/sites/all/themes/test/template.php on line 154

i searched for "at_get_setting()" but found 0 matches.

i then downloaded the latest dev, and then it works.

Only very old versions of 7.x-3.x Adaptivetheme would cause this error, at_get_setting() has been in the core theme for quite some time now, many months in fact.

I am getting this with adaptivetheme installed with the latest -dev versions:

  • adaptivetheme-7.x-1.x-dev 2012-Jul-25 (also tried 7.x-2.3)
  • at_panels_everywhere-7.x-1.x-dev (2012-Jul-06)

I have adaptivetheme core enabled. When I make at_panels_everywhere the default theme, I get an error:
Fatal error: Call to undefined function at_get_setting() in sites/all/themes/at_panels_everywhere/template.php on line 76

I am trying to install this with a Panopoly install with panels_everywhere.

AT Panels Everywhere DEV is only compatible with Adaptivetheme 7.x-3.x-dev.

Please see the project page, its says to use this version.

Thanks, that did it. Sorry I didn't catch it earlier.