Currently there is a check performed in hook_user_update, which throws up an error message if the current user doesn't have ability to edit the account being updated. This breaks in conjunction with rules, and probably anything that might run in a cron job.

This module should only be blocking the ability to administer users - not access to the underlaying api functions.

Files: 
CommentFileSizeAuthor
#1 1677874-administerusersbyrole-remove-access-check-on--update.patch2.12 KBmrfelton
PASSED: [[SimpleTest]]: [MySQL] 1,141 pass(es).
[ View ]

Comments

Status:Active» Needs review
StatusFileSize
new2.12 KB
PASSED: [[SimpleTest]]: [MySQL] 1,141 pass(es).
[ View ]

Patch attached. All tests still pass, and now rules can fire properly.

Status:Needs review» Fixed

This has been committed.

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.